summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-01-14 20:53:45 +0000
committerBrian Evans <grknight@gentoo.org>2015-01-14 20:53:45 +0000
commit80bfa3370a9da2625cf843edd2c7eeb747877b9d (patch)
treee24e5d567767ad5a397baca6c80444f37e3bd694 /dev-php/PEAR-Structures_Graph
parentVersion bump (diff)
downloadgentoo-2-80bfa3370a9da2625cf843edd2c7eeb747877b9d.tar.gz
gentoo-2-80bfa3370a9da2625cf843edd2c7eeb747877b9d.tar.bz2
gentoo-2-80bfa3370a9da2625cf843edd2c7eeb747877b9d.zip
EAPI revbump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key D1F781EFF9F4A3B6)
Diffstat (limited to 'dev-php/PEAR-Structures_Graph')
-rw-r--r--dev-php/PEAR-Structures_Graph/ChangeLog10
-rw-r--r--dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4-r1.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-php/PEAR-Structures_Graph/ChangeLog b/dev-php/PEAR-Structures_Graph/ChangeLog
index d834b11e8819..0d9459800a75 100644
--- a/dev-php/PEAR-Structures_Graph/ChangeLog
+++ b/dev-php/PEAR-Structures_Graph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/PEAR-Structures_Graph
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Structures_Graph/ChangeLog,v 1.18 2014/01/26 18:40:25 olemarkus Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Structures_Graph/ChangeLog,v 1.19 2015/01/14 20:53:45 grknight Exp $
+
+*PEAR-Structures_Graph-1.0.4-r1 (14 Jan 2015)
+
+ 14 Jan 2015; Brian Evans <grknight@gentoo.org>
+ +PEAR-Structures_Graph-1.0.4-r1.ebuild:
+ EAPI revbump
26 Jan 2014; Ole Markus With <olemarkus@gentoo.org>
PEAR-Structures_Graph-1.0.4.ebuild:
diff --git a/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4-r1.ebuild b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..cf9c96171245
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.4-r1.ebuild,v 1.1 2015/01/14 20:53:45 grknight Exp $
+
+# BIG FAT WARNING!
+# Do not use any pear eclass here since pear itself depends on this package.
+# Using the pear eclass will thus create a circular dependency
+
+EAPI="5"
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Graph datastructure manipulation library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+DEPEND="dev-lang/php[pcre(+)]
+ >=dev-php/PEAR-PEAR-1.8.1"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Structures_Graph"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Structures
+
+ dohtml -r docs/html/*
+}