summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-07-23 20:57:25 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-07-23 20:57:25 +0000
commitef9e5df985daa50e004f21123728b0ca1cf7366b (patch)
treed0e8e81565fd371b9483986aec5f96b8ca8b9707 /dev-php/cphplib/cphplib-0.51.ebuild
parentDo not inherit eutils, not needed. (diff)
downloadgentoo-2-ef9e5df985daa50e004f21123728b0ca1cf7366b.tar.gz
gentoo-2-ef9e5df985daa50e004f21123728b0ca1cf7366b.tar.bz2
gentoo-2-ef9e5df985daa50e004f21123728b0ca1cf7366b.zip
Version bump, cleanup ebuild.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'dev-php/cphplib/cphplib-0.51.ebuild')
-rw-r--r--dev-php/cphplib/cphplib-0.51.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/cphplib/cphplib-0.51.ebuild b/dev-php/cphplib/cphplib-0.51.ebuild
new file mode 100644
index 000000000000..d6693c2b6998
--- /dev/null
+++ b/dev-php/cphplib/cphplib-0.51.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/cphplib/cphplib-0.51.ebuild,v 1.1 2006/07/23 20:57:25 chtekk Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="Cute PHP Library (cphplib)."
+HOMEPAGE="http://cphplib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cphplib/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-php/PEAR-DB-1.7.6-r1"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_install() {
+ # install php files
+ php-lib-r1_src_install . *.spec
+ php-lib-r1_src_install . *.inc
+
+ # install documentation
+ dodoc-php ChangeLog COPYRIGHT LGPL README TODO
+}