summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2011-12-14 22:37:15 +0000
committerMatti Bickel <mabi@gentoo.org>2011-12-14 22:37:15 +0000
commite9d809fdf621add45870817a75bfc0a1550c9d64 (patch)
tree1eb419824d1720ffb6ecb866d995c245171b07d3 /dev-php/pecl-haru
parentMoving package from dev-php5 to dev-php category (bug #324665) (diff)
downloadgentoo-2-e9d809fdf621add45870817a75bfc0a1550c9d64.tar.gz
gentoo-2-e9d809fdf621add45870817a75bfc0a1550c9d64.tar.bz2
gentoo-2-e9d809fdf621add45870817a75bfc0a1550c9d64.zip
Moving package from dev-php5 to dev-php category (bug #324665)
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-php/pecl-haru')
-rw-r--r--dev-php/pecl-haru/ChangeLog15
-rw-r--r--dev-php/pecl-haru/metadata.xml9
-rw-r--r--dev-php/pecl-haru/pecl-haru-1.0.0-r1.ebuild28
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-php/pecl-haru/ChangeLog b/dev-php/pecl-haru/ChangeLog
new file mode 100644
index 000000000000..7319cb4adab8
--- /dev/null
+++ b/dev-php/pecl-haru/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for dev-php5/pecl-haru
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-haru/ChangeLog,v 1.1 2011/12/14 22:37:15 mabi Exp $
+
+*pecl-haru-1.0.0-r1 (04 Nov 2010)
+
+ 04 Nov 2010; Matti Bickel <mabi@gentoo.org> +pecl-haru-1.0.0-r1.ebuild:
+ add version that supports minor version slotting
+
+*pecl-haru-1.0.0 (26 Sep 2010)
+
+ 26 Sep 2010; <olemarkus@gentoo.org> +pecl-haru-1.0.0.ebuild,
+ +metadata.xml:
+ Added pecl-haru (bug #249443)
+
diff --git a/dev-php/pecl-haru/metadata.xml b/dev-php/pecl-haru/metadata.xml
new file mode 100644
index 000000000000..0c93320ef0b0
--- /dev/null
+++ b/dev-php/pecl-haru/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <longdescription lang="en">These functions allow you to create PDF documents
+ using the Haru Free PDF Library.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-php/pecl-haru/pecl-haru-1.0.0-r1.ebuild b/dev-php/pecl-haru/pecl-haru-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..921c599460ad
--- /dev/null
+++ b/dev-php/pecl-haru/pecl-haru-1.0.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-haru/pecl-haru-1.0.0-r1.ebuild,v 1.1 2011/12/14 22:37:15 mabi Exp $
+
+EAPI=3
+
+PHP_EXT_NAME="haru"
+
+inherit php-ext-pecl-r2
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png zlib"
+
+DEPEND="media-libs/libharu[png?,zlib?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # config.m4 is broken checking paths, so we need to override it
+ my_conf="--with-haru=/usr"
+ use png && my_conf+=" --with-png-dir=/usr"
+ use zlib && my_conf+=" --with-zlib-dir=/usr"
+
+ php-ext-source-r2_src_configure
+}