summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-04-08 07:11:19 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-04-08 07:11:19 +0000
commitc3a923628b65c2dd98709b23c884d6f72a9722f0 (patch)
treecb0fe3f5c0920e3044cf7e6255c50f7dbe21f8a0 /dev-php/pecl-memcache
parentBump (diff)
downloadgentoo-2-c3a923628b65c2dd98709b23c884d6f72a9722f0.tar.gz
gentoo-2-c3a923628b65c2dd98709b23c884d6f72a9722f0.tar.bz2
gentoo-2-c3a923628b65c2dd98709b23c884d6f72a9722f0.zip
Add php5.5 and php5.4 support + 3.x version bump
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php/pecl-memcache')
-rw-r--r--dev-php/pecl-memcache/ChangeLog8
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild4
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild46
3 files changed, 56 insertions, 2 deletions
diff --git a/dev-php/pecl-memcache/ChangeLog b/dev-php/pecl-memcache/ChangeLog
index 9dbde8fb439a..5c56bd06c72b 100644
--- a/dev-php/pecl-memcache/ChangeLog
+++ b/dev-php/pecl-memcache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/pecl-memcache
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/ChangeLog,v 1.9 2013/04/07 17:49:45 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/ChangeLog,v 1.10 2013/04/08 07:11:19 olemarkus Exp $
+
+*pecl-memcache-3.0.8 (08 Apr 2013)
+
+ 08 Apr 2013; Ole Markus With <olemarkus@gentoo.org>
+ +pecl-memcache-3.0.8.ebuild, pecl-memcache-2.2.7.ebuild:
+ Add php5.5 and php5.4 support + 3.x version bump
*pecl-memcache-2.2.7 (07 Apr 2013)
diff --git a/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild b/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild
index 4d7ec9456b3d..eef3bed505b5 100644
--- a/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild
+++ b/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild,v 1.1 2013/04/07 17:49:45 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild,v 1.2 2013/04/08 07:11:19 olemarkus Exp $
EAPI="4"
PHP_EXT_NAME="memcache"
@@ -8,6 +8,8 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS="README"
+USE_PHP="php5-5 php5-4 php5-3"
+
inherit php-ext-pecl-r2
KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
diff --git a/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild b/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild
new file mode 100644
index 000000000000..6048266b2558
--- /dev/null
+++ b/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild,v 1.1 2013/04/08 07:11:19 olemarkus Exp $
+
+EAPI="5"
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+USE_PHP="php5-5 php5-3 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+
+DESCRIPTION="PHP extension for using memcached."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="+session"
+
+DEPEND="sys-libs/zlib
+ dev-lang/php[session?]"
+RDEPEND="${DEPEND}"
+
+# upstream does not ship any testsuite, so the PHPize test-runner fails.
+RESTRICT='test'
+
+src_configure() {
+ my_conf="--enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session)"
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "memcache.allow_failover" "true"
+ php-ext-source-r2_addtoinifiles "memcache.max_failover_attempts" "20"
+ php-ext-source-r2_addtoinifiles "memcache.chunk_size" "32768"
+ php-ext-source-r2_addtoinifiles "memcache.default_port" "11211"
+ php-ext-source-r2_addtoinifiles "memcache.hash_strategy" "consistent"
+ php-ext-source-r2_addtoinifiles "memcache.hash_function" "crc32"
+ php-ext-source-r2_addtoinifiles "memcache.redundancy" "1"
+ php-ext-source-r2_addtoinifiles "memcache.session_redundancy" "2"
+ php-ext-source-r2_addtoinifiles "memcache.protocol" "ascii"
+}