summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2008-06-03 03:31:42 +0000
committerLuca Longinotti <chtekk@gentoo.org>2008-06-03 03:31:42 +0000
commitcacb8a41dc7118e7fccb46b010e0328bd2c89c11 (patch)
treef3fe39aab1a2fcc8fb7e0e154bfa469e15fae37c /dev-php/xdebug-client/xdebug-client-2.0.3.ebuild
parentRemove old. (diff)
downloadgentoo-2-cacb8a41dc7118e7fccb46b010e0328bd2c89c11.tar.gz
gentoo-2-cacb8a41dc7118e7fccb46b010e0328bd2c89c11.tar.bz2
gentoo-2-cacb8a41dc7118e7fccb46b010e0328bd2c89c11.zip
Version bump.
(Portage version: 2.2_pre7-r1/cvs/Linux 2.6.24-gentoo-r4 Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz)
Diffstat (limited to 'dev-php/xdebug-client/xdebug-client-2.0.3.ebuild')
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.0.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/xdebug-client/xdebug-client-2.0.3.ebuild b/dev-php/xdebug-client/xdebug-client-2.0.3.ebuild
new file mode 100644
index 000000000000..94525c97eb05
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.0.3.ebuild,v 1.1 2008/06/03 03:31:42 chtekk Exp $
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( || ( dev-libs/libedit sys-freebsd/freebsd-lib ) )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}