summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2014-05-03 13:58:25 +0000
committerOle Markus With <olemarkus@gentoo.org>2014-05-03 13:58:25 +0000
commit0a5cf2b4a74ed9e34a222e39517686b636eee975 (patch)
tree1b9faec2762d09e11ae0a4de325c18766af6677c /dev-php/xdebug-client
parentVersion bump (diff)
downloadgentoo-2-0a5cf2b4a74ed9e34a222e39517686b636eee975.tar.gz
gentoo-2-0a5cf2b4a74ed9e34a222e39517686b636eee975.tar.bz2
gentoo-2-0a5cf2b4a74ed9e34a222e39517686b636eee975.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php/xdebug-client')
-rw-r--r--dev-php/xdebug-client/ChangeLog10
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.2.5.ebuild30
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index 122df32c423c..a27cc01f71eb 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xdebug-client
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.69 2013/08/23 13:41:39 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.70 2014/05/03 13:58:25 olemarkus Exp $
+
+*xdebug-client-2.2.5 (03 May 2014)
+
+ 03 May 2014; Ole Markus With <olemarkus@gentoo.org>
+ +xdebug-client-2.2.5.ebuild:
+ Version bump
23 Aug 2013; Agostino Sarubbo <ago@gentoo.org> xdebug-client-2.2.3.ebuild:
Stable for ppc64, wrt bug #480460
diff --git a/dev-php/xdebug-client/xdebug-client-2.2.5.ebuild b/dev-php/xdebug-client/xdebug-client-2.2.5.ebuild
new file mode 100644
index 000000000000..5358d3ae98b4
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.2.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.2.5.ebuild,v 1.1 2014/05/03 13:58:25 olemarkus Exp $
+
+EAPI=5
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with libedit)
+}
+
+src_install() {
+ newbin debugclient xdebug
+}