summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-10-28 11:45:28 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-10-28 11:45:28 +0000
commit2cd025e43ea8f1210410be7634a11c1b235b6392 (patch)
treec62aa00d144c000b679e8457f8f3c13824165a89 /dev-php/xdebug-client
parentunmask gnome-bluetooth stuff and remove iptc from package.use.mask since it's... (diff)
downloadgentoo-2-2cd025e43ea8f1210410be7634a11c1b235b6392.tar.gz
gentoo-2-2cd025e43ea8f1210410be7634a11c1b235b6392.tar.bz2
gentoo-2-2cd025e43ea8f1210410be7634a11c1b235b6392.zip
Version bump from php project overlay
(Portage version: 2.1.3.16)
Diffstat (limited to 'dev-php/xdebug-client')
-rw-r--r--dev-php/xdebug-client/ChangeLog11
-rw-r--r--dev-php/xdebug-client/files/digest-xdebug-client-2.0.13
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.0.1.ebuild34
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index 151f0aca3691..5bb0a7c26fe4 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.6 2007/09/06 15:54:58 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.7 2007/10/28 11:45:27 jokey Exp $
+
+*xdebug-client-2.0.1 (28 Oct 2007)
+
+ 28 Oct 2007; Markus Ullmann <jokey@gentoo.org>
+ +xdebug-client-2.0.1.ebuild:
+ Version bump from php project overlay
+
+ 27 Oct 2007; Jakub Moc <jakub@gentoo.org> +xdebug-client-2.0.1.ebuild:
+ Version bump
06 Sep 2007; Markus Ullmann <jokey@gentoo.org>
-xdebug-client-2.0.0_rc3.ebuild, -xdebug-client-2.0.0_rc4.ebuild:
diff --git a/dev-php/xdebug-client/files/digest-xdebug-client-2.0.1 b/dev-php/xdebug-client/files/digest-xdebug-client-2.0.1
new file mode 100644
index 000000000000..a8b9f96cc1cf
--- /dev/null
+++ b/dev-php/xdebug-client/files/digest-xdebug-client-2.0.1
@@ -0,0 +1,3 @@
+MD5 d942de6225c5a06de7f693b672a44429 xdebug-2.0.1.tgz 279058
+RMD160 a958601000e9d02d20bdd773373befb867ba21b0 xdebug-2.0.1.tgz 279058
+SHA256 e844ee49637b731053bfda07670a9711a572ac7ad84d87ff889785432ebfa260 xdebug-2.0.1.tgz 279058
diff --git a/dev-php/xdebug-client/xdebug-client-2.0.1.ebuild b/dev-php/xdebug-client/xdebug-client-2.0.1.ebuild
new file mode 100644
index 000000000000..0ca8c9f1b631
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.0.1.ebuild,v 1.1 2007/10/28 11:45:27 jokey Exp $
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( || ( dev-libs/libedit sys-freebsd/freebsd-lib ) )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}