summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2005-09-06 07:25:35 +0000
committerStuart Herbert <stuart@gentoo.org>2005-09-06 07:25:35 +0000
commit9c1c2fd685ce1b96ab13a20c73654a86617864df (patch)
tree76b9980986da371a5d9947e4fab33e82087958be /dev-php4/pecl-apc
parentMetadata data for dev-php4 category (diff)
downloadgentoo-2-9c1c2fd685ce1b96ab13a20c73654a86617864df.tar.gz
gentoo-2-9c1c2fd685ce1b96ab13a20c73654a86617864df.tar.bz2
gentoo-2-9c1c2fd685ce1b96ab13a20c73654a86617864df.zip
Initial import for PHP4
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-php4/pecl-apc')
-rw-r--r--dev-php4/pecl-apc/ChangeLog7
-rw-r--r--dev-php4/pecl-apc/Manifest4
-rw-r--r--dev-php4/pecl-apc/files/digest-pecl-apc-3.0.81
-rw-r--r--dev-php4/pecl-apc/metadata.xml5
-rw-r--r--dev-php4/pecl-apc/pecl-apc-3.0.8.ebuild70
5 files changed, 87 insertions, 0 deletions
diff --git a/dev-php4/pecl-apc/ChangeLog b/dev-php4/pecl-apc/ChangeLog
new file mode 100644
index 000000000000..a25278a0c4a5
--- /dev/null
+++ b/dev-php4/pecl-apc/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-php4/pecl-apc
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/ChangeLog,v 1.1 2005/09/06 07:25:35 stuart Exp $
+
+ 18 Aug 2005; <stuart@gentoo.org> ChangeLog:
+ Initial version; replaces older dev-php/* packages
+
diff --git a/dev-php4/pecl-apc/Manifest b/dev-php4/pecl-apc/Manifest
new file mode 100644
index 000000000000..ed1738316d5a
--- /dev/null
+++ b/dev-php4/pecl-apc/Manifest
@@ -0,0 +1,4 @@
+MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
+MD5 cf41d6929c341747c2a5f597f6f84037 ChangeLog 218
+MD5 ce05480db333c4778706b8cec7672c65 pecl-apc-3.0.8.ebuild 2091
+MD5 66795850fe4fb57f021182ccdd3e3203 files/digest-pecl-apc-3.0.8 57
diff --git a/dev-php4/pecl-apc/files/digest-pecl-apc-3.0.8 b/dev-php4/pecl-apc/files/digest-pecl-apc-3.0.8
new file mode 100644
index 000000000000..7dde4bdf1152
--- /dev/null
+++ b/dev-php4/pecl-apc/files/digest-pecl-apc-3.0.8
@@ -0,0 +1 @@
+MD5 a70a14a00275e551e8085f742322433f APC-3.0.8.tgz 75541
diff --git a/dev-php4/pecl-apc/metadata.xml b/dev-php4/pecl-apc/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php4/pecl-apc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php4/pecl-apc/pecl-apc-3.0.8.ebuild b/dev-php4/pecl-apc/pecl-apc-3.0.8.ebuild
new file mode 100644
index 000000000000..d50a3474a6c3
--- /dev/null
+++ b/dev-php4/pecl-apc/pecl-apc-3.0.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/pecl-apc-3.0.8.ebuild,v 1.1 2005/09/06 07:25:35 stuart Exp $
+
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_PECL_PKG="APC"
+PHP_EXT_NAME="apc"
+PHP_EXT_INI="yes"
+
+inherit php-ext-pecl-r1 confutils
+
+IUSE="mmap"
+DESCRIPTION="The Alternative PHP Cache."
+SLOT="0"
+LICENSE="PHP"
+KEYWORDS="~ppc ~x86"
+DEPEND="${DEPEND}
+ !dev-php4/eaccelerator"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_sapi_from cgi apache apache2
+}
+
+src_compile() {
+ has_php
+
+ # PECL-APC does not work with Zend Thread Safety (ZTS)
+ # so abort if we are using PHP compiled with ZTS.
+ if has_zts ; then
+ eerror "PECL-APC doesn't work with a ZTS enabled PHP."
+ eerror "Please disable ZTS by turning the 'threads'"
+ eerror "USE flag off when you compile dev-lang/php."
+ die "PECL-APC does not support ZTS"
+ fi
+
+ my_conf="--enable-apc"
+ enable_extension_enable "apc-mmap" "mmap" 0
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs2 /usr/sbin/apxs2 "optimisation for apache2"
+ enable_extension_with_built_with =${PHP_PKG} apache apxs /usr/sbin/apxs "optimisation for apache1"
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+ dodoc CHANGELOG INSTALL LICENSE NOTICE
+
+ php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
+ php-ext-base-r1_addtoinifiles "apc.optimization" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1000"'
+ php-ext-base-r1_addtoinifiles "apc.ttl" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
+ php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.filters" '""'
+ php-ext-base-r1_addtoinifiles "apc.mmap_file_mask" '""'
+ php-ext-base-r1_addtoinifiles "apc.slam_defense" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
+
+ dodir ${PHP_EXT_SHARED_DIR}
+ insinto ${PHP_EXT_SHARED_DIR}
+ doins apc.php
+}
+
+pkg_postinst() {
+ einfo "The apc.php file shipped with this release of PECL-APC was"
+ einfo "installed into /usr/share/php4/apc/."
+}