summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-09-25 07:58:25 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-09-25 07:58:25 +0000
commit1cc1e3cf82b3f885fb186e011bfa13344e7a22f9 (patch)
tree0a3f02fedb5ac1be3d9a057cb506aa0661e56e0e /dev-php4
parentAdded ~ppc64; bug #149013 (diff)
downloadgentoo-2-1cc1e3cf82b3f885fb186e011bfa13344e7a22f9.tar.gz
gentoo-2-1cc1e3cf82b3f885fb186e011bfa13344e7a22f9.tar.bz2
gentoo-2-1cc1e3cf82b3f885fb186e011bfa13344e7a22f9.zip
Version bump.
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'dev-php4')
-rw-r--r--dev-php4/jpgraph/ChangeLog8
-rw-r--r--dev-php4/jpgraph/files/digest-jpgraph-1.20.53
-rw-r--r--dev-php4/jpgraph/jpgraph-1.20.5.ebuild84
3 files changed, 94 insertions, 1 deletions
diff --git a/dev-php4/jpgraph/ChangeLog b/dev-php4/jpgraph/ChangeLog
index e92fabedc887..a8e6278cb013 100644
--- a/dev-php4/jpgraph/ChangeLog
+++ b/dev-php4/jpgraph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php4/jpgraph
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/jpgraph/ChangeLog,v 1.8 2006/06/29 17:11:13 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/jpgraph/ChangeLog,v 1.9 2006/09/25 07:58:25 sebastian Exp $
+
+*jpgraph-1.20.5 (25 Sep 2006)
+
+ 25 Sep 2006; Sebastian Bergmann <sebastian@gentoo.org>
+ -jpgraph-1.20.2.ebuild, +jpgraph-1.20.5.ebuild:
+ Version bump.
29 Jun 2006; Guy Martin <gmsoft@gentoo.org> jpgraph-1.20.2.ebuild:
Added ~hppa to KEYWORDS.
diff --git a/dev-php4/jpgraph/files/digest-jpgraph-1.20.5 b/dev-php4/jpgraph/files/digest-jpgraph-1.20.5
new file mode 100644
index 000000000000..d9310f6a0c8b
--- /dev/null
+++ b/dev-php4/jpgraph/files/digest-jpgraph-1.20.5
@@ -0,0 +1,3 @@
+MD5 29c4b7487d50cc2186c7e2e6c3e9db43 jpgraph-1.20.5.tar.gz 4472390
+RMD160 9c6728681a5fb40b6789657b0b147fc9136f46ec jpgraph-1.20.5.tar.gz 4472390
+SHA256 43367468406f6e968eb991d25a3de63f19ddbfd2a3871f34cbca325860a1281c jpgraph-1.20.5.tar.gz 4472390
diff --git a/dev-php4/jpgraph/jpgraph-1.20.5.ebuild b/dev-php4/jpgraph/jpgraph-1.20.5.ebuild
new file mode 100644
index 000000000000..11f90aceb1b6
--- /dev/null
+++ b/dev-php4/jpgraph/jpgraph-1.20.5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/jpgraph/jpgraph-1.20.5.ebuild,v 1.1 2006/09/25 07:58:25 sebastian Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+DESCRIPTION="Fully OO graph drawing library for PHP."
+HOMEPAGE="http://www.aditus.nu/jpgraph/"
+SRC_URI="http://members.chello.se/jpgraph/jpgdownloads/${P}.tar.gz"
+LICENSE="QPL-1.0"
+SLOT="0"
+IUSE="truetype"
+
+RDEPEND="${RDEPEND}
+ truetype? ( media-fonts/corefonts )"
+
+need_php_by_category
+
+JPGRAPH_CACHE_DIR="/var/cache/jpgraph"
+COREFONTS_DIR="/usr/share/fonts/corefonts"
+
+pkg_setup() {
+ has_php
+
+ # we need the GD functionality of PHP
+ require_gd
+
+ # check to wich user:group the cache dir will go
+ if has_version "net-www/apache" ; then
+ HTTPD_USER="apache"
+ HTTPD_GROUP="apache"
+ einfo "Configuring cache dir ${JPGRAPH_CACHE_DIR} for Apache."
+ else
+ HTTPD_USER="root"
+ HTTPD_GROUP="root"
+ ewarn "No Apache webserver detected - ${JPGRAPH_CACHE_DIR} will be"
+ ewarn "owned by ${HTTPD_USER}:${HTTPD_GROUP} instead."
+ fi
+}
+
+src_install() {
+ # some patches to adapt the config to Gentoo
+ einfo "Patching jpg-config.inc"
+
+ # patch 1:
+ # make jpgraph use the correct group for file permissions
+
+ sed -i "s|^DEFINE(\"CACHE_FILE_GROUP\",\"wwwadmin\");|DEFINE(\"CACHE_FILE_GROUP\",\"${HTTPD_GROUP}\");|" src/jpg-config.inc
+
+ # patch 2:
+ # make jpgraph use the correct directory for caching
+
+ sed -i "s|.*DEFINE(\"CACHE_DIR\",\"/tmp/jpgraph_cache/\");|DEFINE(\"CACHE_DIR\",\"${JPGRAPH_CACHE_DIR}/\");|" src/jpg-config.inc
+
+ # patch 3:
+ # make jpgraph use the correct directory for the corefonts if the truetype USE flag is set
+
+ if use truetype ; then
+ sed -i "s|.*DEFINE(\"TTF_DIR\",\"/usr/X11R6/lib/X11/fonts/truetype/\");|DEFINE(\"TTF_DIR\",\"${COREFONTS_DIR}/\");|" src/jpg-config.inc
+ fi
+
+ # patch 4:
+ # disable READ_CACHE in jpgraph
+
+ sed -i "s|^DEFINE(\"READ_CACHE\",true);|DEFINE(\"READ_CACHE\",false);|" src/jpg-config.inc
+
+ # install php files
+ einfo "Building list of files to install"
+ php-lib-r1_src_install src `cd src ; find . -type f -print`
+
+ # install documentation
+ einfo "Installing documentation"
+ dodoc-php README QPL.txt
+ dohtml -r docs/*
+
+ # setup the cache dir
+ # cachedir must be world-writable, because PHP/CLI doesn't run
+ # as the apache user!
+ einfo "Setting up the cache dir"
+ keepdir "${JPGRAPH_CACHE_DIR}"
+ fowners ${HTTPD_USER}:${HTTPD_GROUP} "${JPGRAPH_CACHE_DIR}"
+ fperms 700 "${JPGRAPH_CACHE_DIR}"
+}