summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-02-28 11:36:24 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-02-28 11:36:24 +0000
commit7b04f64972f4d86a3ba2e4b62372755f2d6e0072 (patch)
tree7fcea62ce8ada7fe25f6240e75a9829fc1244388 /dev-php4
parentVersion bump (diff)
downloadgentoo-2-7b04f64972f4d86a3ba2e4b62372755f2d6e0072.tar.gz
gentoo-2-7b04f64972f4d86a3ba2e4b62372755f2d6e0072.tar.bz2
gentoo-2-7b04f64972f4d86a3ba2e4b62372755f2d6e0072.zip
Initial ebuild.
(Portage version: 2.1_pre5)
Diffstat (limited to 'dev-php4')
-rw-r--r--dev-php4/pecl-radius/ChangeLog10
-rw-r--r--dev-php4/pecl-radius/Manifest9
-rw-r--r--dev-php4/pecl-radius/files/digest-pecl-radius-1.2.43
-rw-r--r--dev-php4/pecl-radius/metadata.xml5
-rw-r--r--dev-php4/pecl-radius/pecl-radius-1.2.4.ebuild26
5 files changed, 53 insertions, 0 deletions
diff --git a/dev-php4/pecl-radius/ChangeLog b/dev-php4/pecl-radius/ChangeLog
new file mode 100644
index 000000000000..6a6958082575
--- /dev/null
+++ b/dev-php4/pecl-radius/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php4/pecl-radius
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-radius/ChangeLog,v 1.1 2006/02/28 11:36:24 sebastian Exp $
+
+*pecl-radius-1.2.4 (28 Feb 2006)
+
+ 28 Feb 2006; Sebastian Bergmann <sebastian@gentoo.org> +metadata.xml,
+ +pecl-radius-1.2.4.ebuild:
+ Initial ebuild.
+
diff --git a/dev-php4/pecl-radius/Manifest b/dev-php4/pecl-radius/Manifest
new file mode 100644
index 000000000000..df37b0e66254
--- /dev/null
+++ b/dev-php4/pecl-radius/Manifest
@@ -0,0 +1,9 @@
+MD5 fe2b74003267219092ef70b10bd05984 files/digest-pecl-radius-1.2.4 226
+RMD160 6ff8e3d898e84198a1064eaeb5e3733122c53d3f files/digest-pecl-radius-1.2.4 226
+SHA256 f07f0832027367259ad61c275766d220f79353c6c67a964bf81fe4fe33096aba files/digest-pecl-radius-1.2.4 226
+MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
+RMD160 a98db3a086fae3c09a903dadbc05f60443ec4b1a metadata.xml 157
+SHA256 54f8878ca0228e380abbaa4b529806b5533a6b9b51b3b16c0909e906586a91a1 metadata.xml 157
+MD5 f9b9c5274c44c0cf12328b9949c3ffd8 pecl-radius-1.2.4.ebuild 486
+RMD160 c9bd1cf1bcdcb6f4f1ed86ed2e28519055e48a3b pecl-radius-1.2.4.ebuild 486
+SHA256 3f4086c87ec21d52fdcfdc4893a2beaa7af32930f85e8d172b75838b7fe9d2b4 pecl-radius-1.2.4.ebuild 486
diff --git a/dev-php4/pecl-radius/files/digest-pecl-radius-1.2.4 b/dev-php4/pecl-radius/files/digest-pecl-radius-1.2.4
new file mode 100644
index 000000000000..ca84936e77f4
--- /dev/null
+++ b/dev-php4/pecl-radius/files/digest-pecl-radius-1.2.4
@@ -0,0 +1,3 @@
+MD5 3d48ccb9486b9e8839d814d7ff318091 radius-1.2.4.tgz 29599
+RMD160 6c886031a750583df3ffa558dc4a0e155fa9dcf4 radius-1.2.4.tgz 29599
+SHA256 500e455ac429044fa33b07bfb07126230efc28fc6e61f8e6fd959dd032009866 radius-1.2.4.tgz 29599
diff --git a/dev-php4/pecl-radius/metadata.xml b/dev-php4/pecl-radius/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php4/pecl-radius/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php4/pecl-radius/pecl-radius-1.2.4.ebuild b/dev-php4/pecl-radius/pecl-radius-1.2.4.ebuild
new file mode 100644
index 000000000000..c641837a371e
--- /dev/null
+++ b/dev-php4/pecl-radius/pecl-radius-1.2.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-radius/pecl-radius-1.2.4.ebuild,v 1.1 2006/02/28 11:36:24 sebastian Exp $
+
+PHP_EXT_NAME="radius"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~x86"
+DESCRIPTION="Provides full support for RADIUS authentication (RFC 2865) and
+RADIUS accounting (RFC 2866)."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ has_php
+ my_conf="--with-radius"
+ php-ext-pecl-r1_src_compile
+}