summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-07-26 10:32:34 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-07-26 10:32:34 +0000
commitfc8b75f0da97bb45d8ee0c6b319f0f0636d5e538 (patch)
treed96de7da174df44a0e5caba578bbcd7456255329 /dev-php5/eaccelerator
parentVersion bump. (diff)
downloadgentoo-2-fc8b75f0da97bb45d8ee0c6b319f0f0636d5e538.tar.gz
gentoo-2-fc8b75f0da97bb45d8ee0c6b319f0f0636d5e538.tar.bz2
gentoo-2-fc8b75f0da97bb45d8ee0c6b319f0f0636d5e538.zip
* bump
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'dev-php5/eaccelerator')
-rw-r--r--dev-php5/eaccelerator/ChangeLog8
-rw-r--r--dev-php5/eaccelerator/eaccelerator-0.9.5_rc1.ebuild102
-rw-r--r--dev-php5/eaccelerator/files/digest-eaccelerator-0.9.5_rc13
3 files changed, 112 insertions, 1 deletions
diff --git a/dev-php5/eaccelerator/ChangeLog b/dev-php5/eaccelerator/ChangeLog
index 6e545a5a36f9..866408d0b120 100644
--- a/dev-php5/eaccelerator/ChangeLog
+++ b/dev-php5/eaccelerator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/eaccelerator
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/eaccelerator/ChangeLog,v 1.4 2006/07/18 16:44:42 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/eaccelerator/ChangeLog,v 1.5 2006/07/26 10:32:33 voxus Exp $
+
+*eaccelerator-0.9.5_rc1 (26 Jul 2006)
+
+ 26 Jul 2006; Konstantin Arkhipov <voxus@gentoo.org>
+ +eaccelerator-0.9.5_rc1.ebuild:
+ Bump.
18 Jul 2006; Konstantin Arkhipov <voxus@gentoo.org>
eaccelerator-0.9.5_beta2.ebuild:
diff --git a/dev-php5/eaccelerator/eaccelerator-0.9.5_rc1.ebuild b/dev-php5/eaccelerator/eaccelerator-0.9.5_rc1.ebuild
new file mode 100644
index 000000000000..c4aa29e55102
--- /dev/null
+++ b/dev-php5/eaccelerator/eaccelerator-0.9.5_rc1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/eaccelerator/eaccelerator-0.9.5_rc1.ebuild,v 1.1 2006/07/26 10:32:33 voxus Exp $
+
+PHP_EXT_NAME="eaccelerator"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+[[ -z "${EACCELERATOR_CACHEDIR}" ]] && EACCELERATOR_CACHEDIR="/var/cache/eaccelerator"
+
+inherit php-ext-source-r1
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="A PHP Accelerator & Encoder."
+HOMEPAGE="http://www.eaccelerator.net/"
+SRC_URI="mirror://sourceforge/eaccelerator/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="contentcache disassembler inode session sharedmem"
+
+DEPEND="${DEPEND}
+ !dev-php5/pecl-apc"
+
+# Webserver user and group, here for Apache.
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+
+ require_php_sapi_from cgi apache apache2
+
+ if use session ; then
+ require_php_with_use session zlib
+ else
+ require_php_with_use zlib
+ fi
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-eaccelerator=shared"
+
+ use contentcache && my_conf="${my_conf} --with-eaccelerator-content-caching"
+ use disassembler && my_conf="${my_conf} --with-eaccelerator-disassembler"
+ use session && my_conf="${my_conf} --with-eaccelerator-sessions"
+ use sharedmem && my_conf="${my_conf} --with-eaccelerator-shared-memory"
+ use !inode && my_conf="${my_conf} --without-eaccelerator-use-inode"
+
+ php-ext-source-r1_src_compile
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+
+ keepdir "${EACCELERATOR_CACHEDIR}"
+ fowners ${HTTPD_USER}:${HTTPD_GROUP} "${EACCELERATOR_CACHEDIR}"
+ fperms 750 "${EACCELERATOR_CACHEDIR}"
+
+ insinto "/usr/share/${PN}"
+ doins doc/php/*
+ dodoc-php AUTHORS ChangeLog COPYING NEWS README README.eLoader
+
+ php-ext-base-r1_addtoinifiles "eaccelerator.shm_size" '"28"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.cache_dir" "\"${EACCELERATOR_CACHEDIR}\""
+ php-ext-base-r1_addtoinifiles "eaccelerator.enable" '"1"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.optimizer" '"1"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.check_mtime" '"1"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.debug" '"0"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.filter" '""'
+ php-ext-base-r1_addtoinifiles "eaccelerator.shm_max" '"0"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.shm_ttl" '"0"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.shm_prune_period" '"0"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.shm_only" '"0"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.compress" '"1"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.compress_level" '"9"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.keys" '"shm_and_disk"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.sessions" '"shm_and_disk"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.content" '"shm_and_disk"'
+ php-ext-base-r1_addtoinifiles ";eaccelerator.allowed_admin_path" '"/path/where/admin/files/shall/be/allowed"'
+}
+
+pkg_postinst() {
+ # You only need to restart the webserver if you're using mod_php.
+ if built_with_use =${PHP_PKG} apache || built_with_use =${PHP_PKG} apache2 ; then
+ einfo
+ einfo "You need to restart your Apache webserver to activate eAccelerator."
+ einfo
+ fi
+
+ einfo
+ einfo "A series of PHP function is available to manage eAccelerator."
+ einfo "Please see the files in /usr/share/${PN} for some examples"
+ einfo "and informations on those functions and how to use them."
+ einfo
+}
diff --git a/dev-php5/eaccelerator/files/digest-eaccelerator-0.9.5_rc1 b/dev-php5/eaccelerator/files/digest-eaccelerator-0.9.5_rc1
new file mode 100644
index 000000000000..5a368e3eef60
--- /dev/null
+++ b/dev-php5/eaccelerator/files/digest-eaccelerator-0.9.5_rc1
@@ -0,0 +1,3 @@
+MD5 5d03deb399f8f857d92dd092a2c69a87 eaccelerator-0.9.5-rc1.tar.bz2 120221
+RMD160 7e3b81989052ec0c74d62b4f832673bbfda33f8b eaccelerator-0.9.5-rc1.tar.bz2 120221
+SHA256 7200dad2a96c17b5a4c04744061e56dfa5f98fb071984ba8bf8f178707a72a5f eaccelerator-0.9.5-rc1.tar.bz2 120221