summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2008-08-07 15:05:26 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2008-08-07 15:05:26 +0000
commit2fdf6aa40120a736585a07661d2abff51d1c0de4 (patch)
treec9343a6fd5a80038edf21bf1c5463049e1686191 /dev-php5/onphp
parentAdd vde flag to expose new VDE support (diff)
downloadgentoo-2-2fdf6aa40120a736585a07661d2abff51d1c0de4.tar.gz
gentoo-2-2fdf6aa40120a736585a07661d2abff51d1c0de4.tar.bz2
gentoo-2-2fdf6aa40120a736585a07661d2abff51d1c0de4.zip
* bump
(Portage version: 2.2_rc6/cvs/Linux 2.6.25.12-mactel x86_64)
Diffstat (limited to 'dev-php5/onphp')
-rw-r--r--dev-php5/onphp/ChangeLog9
-rw-r--r--dev-php5/onphp/onphp-0.10.12.ebuild33
-rw-r--r--dev-php5/onphp/onphp-1.0.6.ebuild33
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-php5/onphp/ChangeLog b/dev-php5/onphp/ChangeLog
index 1afe6c95df78..3e46bd7496db 100644
--- a/dev-php5/onphp/ChangeLog
+++ b/dev-php5/onphp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-php5/onphp
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/ChangeLog,v 1.60 2008/07/14 17:53:18 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/ChangeLog,v 1.61 2008/08/07 15:05:26 voxus Exp $
+
+*onphp-1.0.6 (07 Aug 2008)
+*onphp-0.10.12 (07 Aug 2008)
+
+ 07 Aug 2008; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +onphp-0.10.12.ebuild, +onphp-1.0.6.ebuild:
+ Version bump.
14 Jul 2008; Konstantin V. Arkhipov <voxus@gentoo.org>
-onphp-0.10.9.ebuild, -onphp-0.10.10.ebuild, onphp-0.10.11.ebuild,
diff --git a/dev-php5/onphp/onphp-0.10.12.ebuild b/dev-php5/onphp/onphp-0.10.12.ebuild
new file mode 100644
index 000000000000..496794acfb43
--- /dev/null
+++ b/dev-php5/onphp/onphp-0.10.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.10.12.ebuild,v 1.1 2008/08/07 15:05:26 voxus Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework."
+HOMEPAGE="http://onphp.org/"
+SRC_URI="http://onphp.org/download/${P}.tar.bz2
+ doc? ( http://onphp.org/download/${PN}-api-${PV}.tar.bz2 )"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+src_install() {
+ has_php
+
+ dodoc `find doc -maxdepth 1 -type f -print`
+
+ if use doc ; then
+ dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
+ fi
+
+ php-lib-r1_src_install ./ global.inc.php.tpl
+ php-lib-r1_src_install ./ `find core main meta -type f -print`
+}
diff --git a/dev-php5/onphp/onphp-1.0.6.ebuild b/dev-php5/onphp/onphp-1.0.6.ebuild
new file mode 100644
index 000000000000..0d048948c37b
--- /dev/null
+++ b/dev-php5/onphp/onphp-1.0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-1.0.6.ebuild,v 1.1 2008/08/07 15:05:26 voxus Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework."
+HOMEPAGE="http://onphp.org/"
+SRC_URI="http://onphp.org/download/${P}.tar.bz2
+ doc? ( http://onphp.org/download/${PN}-api-${PV}.tar.bz2 )"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+src_install() {
+ has_php
+
+ dodoc `find doc -maxdepth 1 -type f -print`
+
+ if use doc ; then
+ dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
+ fi
+
+ php-lib-r1_src_install ./ global.inc.php.tpl
+ php-lib-r1_src_install ./ `find core main meta -type f -print`
+}