summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-04-16 11:52:11 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-04-16 11:52:11 +0000
commitb60a9dea610d48f03784d8130af18abf0ffae0a1 (patch)
tree5c4f655974f19e585dacb1a47786ec64f5b6ad1d /dev-php5/pecl-http
parentRemoved older versions (diff)
downloadgentoo-2-b60a9dea610d48f03784d8130af18abf0ffae0a1.tar.gz
gentoo-2-b60a9dea610d48f03784d8130af18abf0ffae0a1.tar.bz2
gentoo-2-b60a9dea610d48f03784d8130af18abf0ffae0a1.zip
Removed older versions
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/pecl-http')
-rw-r--r--dev-php5/pecl-http/pecl-http-1.6.6.ebuild64
-rw-r--r--dev-php5/pecl-http/pecl-http-1.7.0.ebuild64
2 files changed, 0 insertions, 128 deletions
diff --git a/dev-php5/pecl-http/pecl-http-1.6.6.ebuild b/dev-php5/pecl-http/pecl-http-1.6.6.ebuild
deleted file mode 100644
index 8893d6d2a8c4..000000000000
--- a/dev-php5/pecl-http/pecl-http-1.6.6.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.6.6.ebuild,v 1.5 2010/10/20 14:20:56 hwoarang Exp $
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
-
-EAPI="2"
-
-inherit php-ext-pecl-r1 php-ext-base-r1
-
-KEYWORDS="amd64 x86"
-
-DESCRIPTION="Extended HTTP Support for PHP."
-LICENSE="BSD-2 MIT"
-SLOT="0"
-IUSE=""
-
-DEPEND=">=net-misc/curl-7.19.4
- sys-libs/zlib
- dev-libs/libevent
- || ( <dev-lang/php-5.3[spl] >=dev-lang/php-5.3 )
- >=dev-lang/php-5[hash,session,iconv]
- "
-RDEPEND="${DEPEND}"
-
-src_compile() {
- my_conf="--enable-http \
- --with-http-curl-requests \
- --with-http-zlib-compression \
- --with-http-curl-libevent \
- --with-http-magic-mime"
-
- php-ext-pecl-r1_src_compile
-}
-
-src_install() {
- php-ext-pecl-r1_src_install
-
- php-ext-base-r1_addtoinifiles "http.etag.mode" "MD5"
- php-ext-base-r1_addtoinifiles "http.force_exit" "1"
- php-ext-base-r1_addtoinifiles "http.log.allowed_methods" ""
- php-ext-base-r1_addtoinifiles "http.log.cache" ""
- php-ext-base-r1_addtoinifiles "http.log.composite" ""
- php-ext-base-r1_addtoinifiles "http.log.not_found" ""
- php-ext-base-r1_addtoinifiles "http.log.redirect" ""
- php-ext-base-r1_addtoinifiles "http.only_exceptions" "0"
- php-ext-base-r1_addtoinifiles "http.persistent.handles.ident" "GLOBAL"
- php-ext-base-r1_addtoinifiles "http.persistent.handles.limit" "-1"
- php-ext-base-r1_addtoinifiles "http.request.datashare.connect" "0"
- php-ext-base-r1_addtoinifiles "http.request.datashare.cookie" "0"
- php-ext-base-r1_addtoinifiles "http.request.datashare.dns" "1"
- php-ext-base-r1_addtoinifiles "http.request.datashare.ssl" "0"
- php-ext-base-r1_addtoinifiles "http.request.methods.allowed" ""
- php-ext-base-r1_addtoinifiles "http.request.methods.custom" ""
- php-ext-base-r1_addtoinifiles "http.send.inflate.start_auto" "0"
- php-ext-base-r1_addtoinifiles "http.send.inflate.start_flags" "0"
- php-ext-base-r1_addtoinifiles "http.send.deflate.start_auto" "0"
- php-ext-base-r1_addtoinifiles "http.send.deflate.start_flags" "0"
- php-ext-base-r1_addtoinifiles "http.send.not_found_404" "1"
-}
diff --git a/dev-php5/pecl-http/pecl-http-1.7.0.ebuild b/dev-php5/pecl-http/pecl-http-1.7.0.ebuild
deleted file mode 100644
index 14c6ac9eec9b..000000000000
--- a/dev-php5/pecl-http/pecl-http-1.7.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.7.0.ebuild,v 1.1 2010/11/04 13:41:07 mabi Exp $
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
-
-EAPI="2"
-
-inherit php-ext-pecl-r1 php-ext-base-r1
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Extended HTTP Support for PHP."
-LICENSE="BSD-2 MIT"
-SLOT="0"
-IUSE=""
-
-DEPEND=">=net-misc/curl-7.19.4
- sys-libs/zlib
- dev-libs/libevent
- || ( <dev-lang/php-5.3[spl] >=dev-lang/php-5.3 )
- >=dev-lang/php-5[hash,session,iconv]
- "
-RDEPEND="${DEPEND}"
-
-src_compile() {
- my_conf="--enable-http \
- --with-http-curl-requests \
- --with-http-zlib-compression \
- --with-http-curl-libevent \
- --with-http-magic-mime"
-
- php-ext-pecl-r1_src_compile
-}
-
-src_install() {
- php-ext-pecl-r1_src_install
-
- php-ext-base-r1_addtoinifiles "http.etag.mode" "MD5"
- php-ext-base-r1_addtoinifiles "http.force_exit" "1"
- php-ext-base-r1_addtoinifiles "http.log.allowed_methods" ""
- php-ext-base-r1_addtoinifiles "http.log.cache" ""
- php-ext-base-r1_addtoinifiles "http.log.composite" ""
- php-ext-base-r1_addtoinifiles "http.log.not_found" ""
- php-ext-base-r1_addtoinifiles "http.log.redirect" ""
- php-ext-base-r1_addtoinifiles "http.only_exceptions" "0"
- php-ext-base-r1_addtoinifiles "http.persistent.handles.ident" "GLOBAL"
- php-ext-base-r1_addtoinifiles "http.persistent.handles.limit" "-1"
- php-ext-base-r1_addtoinifiles "http.request.datashare.connect" "0"
- php-ext-base-r1_addtoinifiles "http.request.datashare.cookie" "0"
- php-ext-base-r1_addtoinifiles "http.request.datashare.dns" "1"
- php-ext-base-r1_addtoinifiles "http.request.datashare.ssl" "0"
- php-ext-base-r1_addtoinifiles "http.request.methods.allowed" ""
- php-ext-base-r1_addtoinifiles "http.request.methods.custom" ""
- php-ext-base-r1_addtoinifiles "http.send.inflate.start_auto" "0"
- php-ext-base-r1_addtoinifiles "http.send.inflate.start_flags" "0"
- php-ext-base-r1_addtoinifiles "http.send.deflate.start_auto" "0"
- php-ext-base-r1_addtoinifiles "http.send.deflate.start_flags" "0"
- php-ext-base-r1_addtoinifiles "http.send.not_found_404" "1"
-}