summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2005-12-18 21:26:23 +0000
committerLuca Longinotti <chtekk@gentoo.org>2005-12-18 21:26:23 +0000
commit86b01ea74f2746c6a5d1de281000892f3d8e2127 (patch)
tree3c833e6ce8c2c2804d826e5f0214c1bdd7c32509 /dev-php5/pecl-pdo-mysql/pecl-pdo-mysql-1.0.1.ebuild
parentDrop gtk useflag for new revision, as it does not handle Unicode correctly, l... (diff)
downloadgentoo-2-86b01ea74f2746c6a5d1de281000892f3d8e2127.tar.gz
gentoo-2-86b01ea74f2746c6a5d1de281000892f3d8e2127.tar.bz2
gentoo-2-86b01ea74f2746c6a5d1de281000892f3d8e2127.zip
Fix Gentoo bug #115921.
(Portage version: 2.0.53)
Diffstat (limited to 'dev-php5/pecl-pdo-mysql/pecl-pdo-mysql-1.0.1.ebuild')
-rw-r--r--dev-php5/pecl-pdo-mysql/pecl-pdo-mysql-1.0.1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-php5/pecl-pdo-mysql/pecl-pdo-mysql-1.0.1.ebuild b/dev-php5/pecl-pdo-mysql/pecl-pdo-mysql-1.0.1.ebuild
index e9febe16514c..22c246349c1d 100644
--- a/dev-php5/pecl-pdo-mysql/pecl-pdo-mysql-1.0.1.ebuild
+++ b/dev-php5/pecl-pdo-mysql/pecl-pdo-mysql-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo-mysql/pecl-pdo-mysql-1.0.1.ebuild,v 1.1 2005/12/18 01:41:44 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo-mysql/pecl-pdo-mysql-1.0.1.ebuild,v 1.2 2005/12/18 21:26:23 chtekk Exp $
PHP_EXT_NAME="pdo_mysql"
PHP_EXT_PECL_PKG="PDO_MYSQL"
@@ -35,6 +35,15 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # Fix Gentoo bug #115921
+ epatch "${FILESDIR}/config-sed.patch"
+}
+
src_compile() {
has_php
my_conf="--with-pdo-mysql=/usr"