summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-05-01 16:03:29 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-05-01 16:03:29 +0000
commite109124a3ce6a093951cd4e11460b1ba3d8af2ae (patch)
treeb489dc372bc09168043f6bdfb3572b6cf44a8dcb /dev-php5/pecl-syck
parentdatadir patch from Aleksey Kunitskiy via bug #219936 (diff)
downloadgentoo-2-e109124a3ce6a093951cd4e11460b1ba3d8af2ae.tar.gz
gentoo-2-e109124a3ce6a093951cd4e11460b1ba3d8af2ae.tar.bz2
gentoo-2-e109124a3ce6a093951cd4e11460b1ba3d8af2ae.zip
assuring that php was built with USE='spl hash', thanks to Nick P in bug 219405
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-php5/pecl-syck')
-rw-r--r--dev-php5/pecl-syck/ChangeLog7
-rw-r--r--dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild8
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-php5/pecl-syck/ChangeLog b/dev-php5/pecl-syck/ChangeLog
index 46256dc07e0e..ff91304f9f29 100644
--- a/dev-php5/pecl-syck/ChangeLog
+++ b/dev-php5/pecl-syck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/pecl-syck
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-syck/ChangeLog,v 1.14 2008/03/31 21:20:28 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-syck/ChangeLog,v 1.15 2008/05/01 16:03:29 hoffie Exp $
+
+ 01 May 2008; Christian Hoffmann <hoffie@gentoo.org>
+ pecl-syck-0.9.2.ebuild:
+ assuring that php was built with USE='spl hash', thanks to Nick P in bug
+ 219405
31 Mar 2008; Markus Meier <maekke@gentoo.org> pecl-syck-0.9.2.ebuild:
amd64 stable, bug #208550
diff --git a/dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild b/dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild
index b34011a67fe2..fc14f1d9c2fb 100644
--- a/dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild
+++ b/dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild,v 1.6 2008/03/31 21:20:28 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild,v 1.7 2008/05/01 16:03:29 hoffie Exp $
PHP_EXT_NAME="syck"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS="CHANGELOG TODO"
-inherit php-ext-pecl-r1
+inherit php-ext-pecl-r1 depend.php
KEYWORDS="amd64 ppc ppc64 x86"
@@ -20,3 +20,7 @@ DEPEND="dev-libs/syck"
RDEPEND="${DEPEND}"
need_php_by_category
+
+pkg_setup() {
+ require_php_with_use spl hash
+}