summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-11 21:29:04 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-11 21:29:04 +0000
commit9f88da06bc537d1319dd283bf4f03c154b3a77ff (patch)
tree7cc8ba35d6f916b48e0f5200e4fdf2d0c4434b67 /dev-php5/phpunit
parentVersion bump, from the php overlay (diff)
downloadgentoo-2-9f88da06bc537d1319dd283bf4f03c154b3a77ff.tar.gz
gentoo-2-9f88da06bc537d1319dd283bf4f03c154b3a77ff.tar.bz2
gentoo-2-9f88da06bc537d1319dd283bf4f03c154b3a77ff.zip
Version bump, from the php overlay
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-php5/phpunit')
-rw-r--r--dev-php5/phpunit/ChangeLog7
-rw-r--r--dev-php5/phpunit/phpunit-3.2.10.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index 979bb14dc9ec..61818cf02917 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.13 2008/02/05 08:55:45 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.14 2008/02/11 21:29:04 armin76 Exp $
+
+*phpunit-3.2.10 (11 Feb 2008)
+
+ 11 Feb 2008; Raúl Porcel <armin76@gentoo.org> +phpunit-3.2.10.ebuild:
+ Version bump, from the php overlay
05 Feb 2008; Christian Faulhammer <opfer@gentoo.org> phpunit-3.2.8.ebuild:
stable x86, bug 208848
diff --git a/dev-php5/phpunit/phpunit-3.2.10.ebuild b/dev-php5/phpunit/phpunit-3.2.10.ebuild
new file mode 100644
index 000000000000..f9d801c9bbfa
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.2.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.2.10.ebuild,v 1.1 2008/02/11 21:29:04 armin76 Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+
+DESCRIPTION="Unit Testing framework for PHP 5."
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.0_rc2
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use pcre reflection spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}