summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-08-31 09:56:24 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-08-31 09:56:24 +0000
commitd36a03e9c579b80a25e041df416e97159caa4fd0 (patch)
treec23c52ff575e78e4387a0120f15c6fb3704c486e /dev-php5
parentPort from project overlay (diff)
downloadgentoo-2-d36a03e9c579b80a25e041df416e97159caa4fd0.tar.gz
gentoo-2-d36a03e9c579b80a25e041df416e97159caa4fd0.tar.bz2
gentoo-2-d36a03e9c579b80a25e041df416e97159caa4fd0.zip
Port from project overlay
(Portage version: 2.1.3.7)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/znf/ChangeLog7
-rw-r--r--dev-php5/znf/files/digest-znf-0.7.93
-rw-r--r--dev-php5/znf/znf-0.7.9.ebuild43
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-php5/znf/ChangeLog b/dev-php5/znf/ChangeLog
index 30aefda8ea77..6f6ad42741c9 100644
--- a/dev-php5/znf/ChangeLog
+++ b/dev-php5/znf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/znf
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/znf/ChangeLog,v 1.5 2007/03/18 03:21:08 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/znf/ChangeLog,v 1.6 2007/08/31 09:56:24 jokey Exp $
+
+*znf-0.7.9 (31 Aug 2007)
+
+ 31 Aug 2007; Markus Ullmann <jokey@gentoo.org> +znf-0.7.9.ebuild:
+ Port from project overlay
18 Mar 2007; Luca Longinotti <chtekk@gentoo.org> znf-0.7.6.ebuild:
Cleanup.
diff --git a/dev-php5/znf/files/digest-znf-0.7.9 b/dev-php5/znf/files/digest-znf-0.7.9
new file mode 100644
index 000000000000..bc5810749f72
--- /dev/null
+++ b/dev-php5/znf/files/digest-znf-0.7.9
@@ -0,0 +1,3 @@
+MD5 8fddb0c78e377fe9549d30b7b7d6f193 ZNF-0.7.9.tgz 810611
+RMD160 b6782598ffe0c83ca465eec2a01c1ee551ed3223 ZNF-0.7.9.tgz 810611
+SHA256 b04316c92336ab032e58bc95d269e1dbdd7b0a6d4e8a39f4dd0d5f0aa8f46c70 ZNF-0.7.9.tgz 810611
diff --git a/dev-php5/znf/znf-0.7.9.ebuild b/dev-php5/znf/znf-0.7.9.ebuild
new file mode 100644
index 000000000000..262f7f20d498
--- /dev/null
+++ b/dev-php5/znf/znf-0.7.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/znf/znf-0.7.9.ebuild,v 1.1 2007/08/31 09:56:24 jokey Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~sparc ~x86"
+
+MY_P="ZNF-${PV}"
+
+DESCRIPTION="PHP5 MVC framework for enterprise web applications."
+HOMEPAGE="http://znf.zeronotice.com/"
+SRC_URI="http://pear.zeronotice.org/get/${MY_P}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND=""
+RDEPEND="!minimal? ( >=dev-php/PEAR-DB-1.7.6-r1
+ >=dev-php/smarty-2.6.10-r1 )"
+
+S="${WORKDIR}/${MY_P}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use xml xsl
+
+ # We need to initialize the channel, otherwise install fails
+ # because of XML parsing error due to unknown DTDs
+ local chan="pear.zeronotice.org"
+ einfo "Initializing and updating ${chan} channel..."
+ pear channel-discover ${chan}
+ pear channel-update ${chan}
+}
+
+pkg_postinst() {
+ has_php
+ if ! built_with_use -o =${PHP_PKG} pdo pdo-external && ! has_version dev-php5/pecl-pdo ; then
+ elog "${PN} can optionally use PDO features. If you want those,"
+ elog "re-emerge ${PHP_PKG} with either USE=\"pdo\" or USE=\"pdo-external\"."
+ fi
+}