summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-07-02 02:51:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-07-02 02:51:59 +0000
commitf5c57bc999a17e777e4d4dfceb4d878221d94835 (patch)
tree2a4ba6c467e6704a854db606f6b14e1a70a3fe42 /dev-php5
parentVersion bump. (diff)
downloadgentoo-2-f5c57bc999a17e777e4d4dfceb4d878221d94835.tar.gz
gentoo-2-f5c57bc999a17e777e4d4dfceb4d878221d94835.tar.bz2
gentoo-2-f5c57bc999a17e777e4d4dfceb4d878221d94835.zip
Version bump.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-memcache/ChangeLog8
-rw-r--r--dev-php5/pecl-memcache/files/digest-pecl-memcache-2.0.43
-rw-r--r--dev-php5/pecl-memcache/pecl-memcache-2.0.4.ebuild37
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-php5/pecl-memcache/ChangeLog b/dev-php5/pecl-memcache/ChangeLog
index d2c711388358..904a5953f095 100644
--- a/dev-php5/pecl-memcache/ChangeLog
+++ b/dev-php5/pecl-memcache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/pecl-memcache
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.12 2006/05/03 13:09:58 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.13 2006/07/02 02:51:59 robbat2 Exp $
+
+*pecl-memcache-2.0.4 (02 Jul 2006)
+
+ 02 Jul 2006; Robin H. Johnson <robbat2@gentoo.org>
+ +pecl-memcache-2.0.4.ebuild:
+ Version bump.
03 May 2006; Gustavo Zacarias <gustavoz@gentoo.org>
pecl-memcache-2.0.1.ebuild:
diff --git a/dev-php5/pecl-memcache/files/digest-pecl-memcache-2.0.4 b/dev-php5/pecl-memcache/files/digest-pecl-memcache-2.0.4
new file mode 100644
index 000000000000..ad07cfbab024
--- /dev/null
+++ b/dev-php5/pecl-memcache/files/digest-pecl-memcache-2.0.4
@@ -0,0 +1,3 @@
+MD5 35d46450ae9728856a2cc98cb8ec053c memcache-2.0.4.tgz 17778
+RMD160 da27515d2d86a4bcae130dac6b89e78ab44136ce memcache-2.0.4.tgz 17778
+SHA256 548419a9ff84840576ce547e3b2c6111ddebd4ce909f78a8b82b55293940e21e memcache-2.0.4.tgz 17778
diff --git a/dev-php5/pecl-memcache/pecl-memcache-2.0.4.ebuild b/dev-php5/pecl-memcache/pecl-memcache-2.0.4.ebuild
new file mode 100644
index 000000000000..f246419d91b7
--- /dev/null
+++ b/dev-php5/pecl-memcache/pecl-memcache-2.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/pecl-memcache-2.0.4.ebuild,v 1.1 2006/07/02 02:51:59 robbat2 Exp $
+
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="hppa ~ppc ~ppc64 sparc ~x86 ~amd64"
+DESCRIPTION="PHP extension for using memcached."
+LICENSE="PHP"
+SLOT="0"
+IUSE=""
+
+DEPEND="${DEPEND}
+ sys-libs/zlib"
+
+need_php_by_category
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # fix bug #117990 better, without using a patch
+ # upstream has the file with CRLF instead of LF
+ edos2unix "${S}/config.m4"
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-memcache --with-zlib-dir=/usr"
+ php-ext-pecl-r1_src_compile
+}