summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-03-29 20:51:41 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-03-29 20:51:41 +0000
commit1e06876a6d04e1175658c0ec802bca730226de40 (patch)
treef3593525d4160888c8f2d0032d75f0acdbcb3664 /dev-php
parentFix underlinking, convert to vala eclass (diff)
downloadgentoo-2-1e06876a6d04e1175658c0ec802bca730226de40.tar.gz
gentoo-2-1e06876a6d04e1175658c0ec802bca730226de40.tar.bz2
gentoo-2-1e06876a6d04e1175658c0ec802bca730226de40.zip
Revbump fixing bug 460836
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-radius/ChangeLog8
-rw-r--r--dev-php/pecl-radius/files/radius_long.patch15
-rw-r--r--dev-php/pecl-radius/pecl-radius-1.2.5-r2.ebuild4
-rw-r--r--dev-php/pecl-radius/pecl-radius-1.2.5-r3.ebuild38
4 files changed, 62 insertions, 3 deletions
diff --git a/dev-php/pecl-radius/ChangeLog b/dev-php/pecl-radius/ChangeLog
index 78e9796f2275..e708d2c7d68e 100644
--- a/dev-php/pecl-radius/ChangeLog
+++ b/dev-php/pecl-radius/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/pecl-radius
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-radius/ChangeLog,v 1.3 2013/03/05 11:41:05 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-radius/ChangeLog,v 1.4 2013/03/29 20:51:41 olemarkus Exp $
+
+*pecl-radius-1.2.5-r3 (29 Mar 2013)
+
+ 29 Mar 2013; Ole Markus With <olemarkus@gentoo.org> +files/radius_long.patch,
+ +pecl-radius-1.2.5-r3.ebuild, pecl-radius-1.2.5-r2.ebuild:
+ Revbump fixing bug 460836
05 Mar 2013; Ole Markus With <olemarkus@gentoo.org>
-pecl-radius-1.2.5-r1.ebuild:
diff --git a/dev-php/pecl-radius/files/radius_long.patch b/dev-php/pecl-radius/files/radius_long.patch
new file mode 100644
index 000000000000..090674c4f189
--- /dev/null
+++ b/dev-php/pecl-radius/files/radius_long.patch
@@ -0,0 +1,15 @@
+Gentoo bug: 460836
+Upstream bug: 60885
+
+diff -u php-radius-1.2.5/radius-1.2.5/radius.c php-radius-1.2.5/radius-1.2.5/radius.c
+--- php-radius-1.2.5/radius-1.2.5/radius.c
++++ php-radius-1.2.5/radius-1.2.5/radius.c
+@@ -265,7 +265,7 @@
+ /* {{{ proto bool radius_create_request(desc, code) */
+ PHP_FUNCTION(radius_create_request)
+ {
+- int code;
++ long code;
+ radius_descriptor *raddesc;
+ zval *z_radh;
+
diff --git a/dev-php/pecl-radius/pecl-radius-1.2.5-r2.ebuild b/dev-php/pecl-radius/pecl-radius-1.2.5-r2.ebuild
index b4d1a6e02f87..b3d6dfbc8fda 100644
--- a/dev-php/pecl-radius/pecl-radius-1.2.5-r2.ebuild
+++ b/dev-php/pecl-radius/pecl-radius-1.2.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-radius/pecl-radius-1.2.5-r2.ebuild,v 1.1 2013/01/24 22:05:11 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-radius/pecl-radius-1.2.5-r2.ebuild,v 1.2 2013/03/29 20:51:41 olemarkus Exp $
EAPI=5
@@ -8,7 +8,7 @@ PHP_EXT_NAME="radius"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
-USE_PHP="php5-3 php5-4"
+USE_PHP="php5-5 php5-3 php5-4"
inherit php-ext-pecl-r2
diff --git a/dev-php/pecl-radius/pecl-radius-1.2.5-r3.ebuild b/dev-php/pecl-radius/pecl-radius-1.2.5-r3.ebuild
new file mode 100644
index 000000000000..f80fdbbedb37
--- /dev/null
+++ b/dev-php/pecl-radius/pecl-radius-1.2.5-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-radius/pecl-radius-1.2.5-r3.ebuild,v 1.1 2013/03/29 20:51:41 olemarkus Exp $
+
+EAPI=5
+
+PHP_EXT_NAME="radius"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-5 php5-3 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Provides full support for RADIUS authentication (RFC 2865) and RADIUS accounting (RFC 2866)."
+LICENSE="BSD BSD-2"
+SLOT="0"
+IUSE="examples"
+
+src_prepare() {
+ # Remove this in the next release
+ if use php_targets_php5-4 ; then
+ sed -i -e 's,function_entry,zend_function_entry,' \
+ "${WORKDIR}/php5.4/radius.c"
+ fi
+ if use php_targets_php5-5 ; then
+ sed -i -e 's,function_entry,zend_function_entry,' \
+ "${WORKDIR}/php5.5/radius.c"
+ fi
+ local slot orig_s="${PHP_EXT_S}"
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch "${FILESDIR}/radius_long.patch"
+ done
+ php-ext-source-r2_src_prepare
+}