summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-08-01 04:45:10 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-08-01 04:45:10 +0000
commit31d8d9705f31169b6014a904383af940c39954c6 (patch)
tree2dabee3eb163a1a75d1064dc7f9418077aa22bd4 /dev-php
parentVersion bump #141246 by David Brown. (diff)
downloadgentoo-2-31d8d9705f31169b6014a904383af940c39954c6.tar.gz
gentoo-2-31d8d9705f31169b6014a904383af940c39954c6.tar.bz2
gentoo-2-31d8d9705f31169b6014a904383af940c39954c6.zip
Version bump.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-PEAR/ChangeLog8
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.4.10.ebuild133
-rw-r--r--dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.4.1012
3 files changed, 152 insertions, 1 deletions
diff --git a/dev-php/PEAR-PEAR/ChangeLog b/dev-php/PEAR-PEAR/ChangeLog
index 8c09b9f12dea..bb93554378c9 100644
--- a/dev-php/PEAR-PEAR/ChangeLog
+++ b/dev-php/PEAR-PEAR/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/PEAR-PEAR
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.69 2006/07/29 22:29:46 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.70 2006/08/01 04:45:10 sebastian Exp $
+
+*PEAR-PEAR-1.4.10 (01 Aug 2006)
+
+ 01 Aug 2006; Sebastian Bergmann <sebastian@gentoo.org>
+ +PEAR-PEAR-1.4.10.ebuild:
+ Version bump.
29 Jul 2006; Luca Longinotti <chtekk@gentoo.org>
-files/fix-packagingroot-1.4.6.patch, -PEAR-PEAR-1.4.6-r1.ebuild:
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.10.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.10.ebuild
new file mode 100644
index 000000000000..0ae318cc45a5
--- /dev/null
+++ b/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.10.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/PEAR-PEAR-1.4.10.ebuild,v 1.1 2006/08/01 04:45:10 sebastian Exp $
+
+inherit depend.php
+
+ARCHIVE_TAR="1.3.1"
+CONSOLE_GETOPT="1.2"
+PEAR="1.4.10"
+XML_RPC="1.5.0"
+
+[ -z "${PEAR_CACHEDIR}" ] && PEAR_CACHEDIR="/tmp/pear/cache"
+
+DESCRIPTION="PEAR Base System (PEAR, Archive_Tar, Console_Getopt, XML_RPC)."
+HOMEPAGE="http://pear.php.net/"
+SRC_URI="http://pear.php.net/get/Archive_Tar-${ARCHIVE_TAR}.tgz
+ http://pear.php.net/get/Console_Getopt-${CONSOLE_GETOPT}.tgz
+ http://pear.php.net/get/XML_RPC-${XML_RPC}.tgz
+ http://pear.php.net/get/PEAR-${PEAR}.tgz"
+
+LICENSE="PHP"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# we deliberately force people to remove their old PEAR installations,
+# and any package which may have put an old-style PEAR installation onto
+# the box
+
+DEPEND="dev-lang/php
+ !dev-php/php
+ !dev-php/php-cgi
+ !dev-php/mod_php
+ !<dev-php/PEAR-PEAR-1.3.6-r2
+ !dev-php/PEAR-Archive_Tar
+ !dev-php/PEAR-Console_Getopt
+ !dev-php/PEAR-XML_RPC"
+
+pkg_setup() {
+ # we call this here, to ensure that the eclass picks the right
+ # version of php for the job
+ require_php_cli
+
+ # we check that PHP was compiled with the correct USE flags
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ require_php_with_use cli pcre expat zlib
+ else
+ require_php_with_use cli pcre xml zlib
+ fi
+}
+
+src_install() {
+ require_php_cli
+
+ # Prevent SNMP related sandbox violoation.
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/
+
+ mkdir -p "${WORKDIR}/PEAR/XML/RPC"
+
+ # Install PEAR Package.
+ cp -r "${WORKDIR}/PEAR-${PEAR}/OS" "${WORKDIR}/PEAR/"
+ cp -r "${WORKDIR}/PEAR-${PEAR}/PEAR" "${WORKDIR}/PEAR/"
+ cp "${WORKDIR}/PEAR-${PEAR}/PEAR.php" "${WORKDIR}/PEAR/PEAR.php"
+ cp "${WORKDIR}/PEAR-${PEAR}/System.php" "${WORKDIR}/PEAR/System.php"
+
+ # Prepare /usr/bin/pear script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pearcmd.php" "${WORKDIR}/PEAR/pearcmd.php"
+ sed -i "s:@pear_version@:${PEAR}:g" "${WORKDIR}/PEAR/pearcmd.php"
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pear.sh" "${WORKDIR}/PEAR/pear"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pear" || die
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pear" || die
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pear" || die
+ sed -i "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=16M:g" "${WORKDIR}/PEAR/pear" || die
+
+ # Prepare /usr/bin/peardev script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/peardev.sh" "${WORKDIR}/PEAR/peardev"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/peardev" || die
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/peardev" || die
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/peardev" || die
+
+ # Prepare /usr/bin/pecl script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/peclcmd.php" "${WORKDIR}/PEAR/peclcmd.php"
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pecl.sh" "${WORKDIR}/PEAR/pecl"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pecl" || die
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pecl" || die
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pecl" || die
+
+ # Prepare PEAR/Dependency2.php.
+ sed -i "s:@PEAR-VER@:${PEAR}:g" "${WORKDIR}/PEAR/PEAR/Dependency2.php" || die
+
+ # Install Archive_Tar Package.
+ cp -r "${WORKDIR}/Archive_Tar-${ARCHIVE_TAR}/Archive" "${WORKDIR}/PEAR/Archive"
+
+ # Install Console_Getopt Package.
+ cp -r "${WORKDIR}/Console_Getopt-${CONSOLE_GETOPT}/Console" "${WORKDIR}/PEAR/"
+
+ # Install XML_RPC Package.
+ cp "${WORKDIR}/XML_RPC-${XML_RPC}/RPC.php" "${WORKDIR}/PEAR/XML/RPC.php"
+ cp "${WORKDIR}/XML_RPC-${XML_RPC}/Server.php" "${WORKDIR}/PEAR/XML/RPC/Server.php"
+
+ # Finalize installation.
+ cd "${WORKDIR}/PEAR"
+ insinto /usr/share/php
+ doins -r Archive Console OS PEAR XML *.php
+ dobin pear peardev pecl
+
+ insinto /etc
+ doins "${FILESDIR}/pear.conf"
+ sed -e "s|s:SUBSTLEN:\"SUBSTITUTEME\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" -i "${D}/etc/pear.conf"
+
+ keepdir "${PEAR_CACHEDIR}"
+ fperms 755 "${PEAR_CACHEDIR}"
+}
+
+pkg_preinst() {
+ rm -f "${ROOT}/etc/pear.conf"
+}
+
+pkg_postinst() {
+ if has_version "<${PV}" ; then
+ ewarn "The location of the local PEAR repository has been changed"
+ ewarn "from /usr/lib/php to /usr/share/php."
+ fi
+
+ # Update PEAR channels as needed, add new ones to the list if needed
+ pearchans="pear.php.net pecl.php.net components.ez.no pear.phpdb.org pear.phing.info pear.symfony-project.com"
+
+ for chan in ${pearchans} ; do
+ pear channel-discover ${chan}
+ pear channel-update ${chan}
+ done
+}
diff --git a/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.4.10 b/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.4.10
new file mode 100644
index 000000000000..fd424f2bed5f
--- /dev/null
+++ b/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.4.10
@@ -0,0 +1,12 @@
+MD5 31e54ce401302065d43888223a0be4d9 Archive_Tar-1.3.1.tgz 15102
+RMD160 e4d94299018d49835c9adb5d0d0bb7a4f3ee7fac Archive_Tar-1.3.1.tgz 15102
+SHA256 f128b58b249d4f182bdf846c6762462468dbfda045ccb332858e62934d655bf6 Archive_Tar-1.3.1.tgz 15102
+MD5 8f9ec8253c04350bc01ee7ca941e24b6 Console_Getopt-1.2.tgz 3370
+RMD160 d9bebe03b52a59b35a4d0fd0825da069037aa000 Console_Getopt-1.2.tgz 3370
+SHA256 90bc64b35832af79625ccd7a1cd981ae26adbe58e1296a052cc3947d9c959e0c Console_Getopt-1.2.tgz 3370
+MD5 ed27ba53deaf651f98e4a314ba7ddb32 PEAR-1.4.10.tgz 284880
+RMD160 d15a460d91f577b3a81efe7ad1dfa9436f4d2f9e PEAR-1.4.10.tgz 284880
+SHA256 ae634180f74faef112d5c3477f1e1212a5a8343b55079f54efdd6a2c07e8e059 PEAR-1.4.10.tgz 284880
+MD5 9f9205d8c8b3ca07a50c5d332c6fb722 XML_RPC-1.5.0.tgz 31619
+RMD160 866d2edcb68d6bb400d5a0364852ac62e267a3c4 XML_RPC-1.5.0.tgz 31619
+SHA256 d1e42d0e11a649cd0ca5cd3bbb3ced2f0984cdcde263d9c45ce6737405258edf XML_RPC-1.5.0.tgz 31619