summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTal Peer <coredumb@gentoo.org>2004-01-24 17:14:34 +0000
committerTal Peer <coredumb@gentoo.org>2004-01-24 17:14:34 +0000
commit478a7d406fae7f3925078d20b8f06e0f41130266 (patch)
treed54324c6331f8aa8b3f3ee81519a8e0d950851b9 /dev-php
parentFixed a path problem (diff)
downloadgentoo-2-478a7d406fae7f3925078d20b8f06e0f41130266.tar.gz
gentoo-2-478a7d406fae7f3925078d20b8f06e0f41130266.tar.bz2
gentoo-2-478a7d406fae7f3925078d20b8f06e0f41130266.zip
Version bump, now uses the bundled libsqlite.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PECL-sqlite/ChangeLog8
-rw-r--r--dev-php/PECL-sqlite/Manifest10
-rw-r--r--dev-php/PECL-sqlite/PECL-sqlite-1.0-r1.ebuild29
-rw-r--r--dev-php/PECL-sqlite/PECL-sqlite-1.0.2.ebuild28
-rw-r--r--dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild4
-rw-r--r--dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0-r11
-rw-r--r--dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0.21
7 files changed, 75 insertions, 6 deletions
diff --git a/dev-php/PECL-sqlite/ChangeLog b/dev-php/PECL-sqlite/ChangeLog
index 2d40b23eb369..4fd9eecc1bfd 100644
--- a/dev-php/PECL-sqlite/ChangeLog
+++ b/dev-php/PECL-sqlite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/PECL-sqlite
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/ChangeLog,v 1.3 2003/10/14 03:41:09 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/ChangeLog,v 1.4 2004/01/24 17:14:34 coredumb Exp $
+
+*PECL-sqlite-1.0.2 (24 Jan 2004)
+
+ 24 Jan 2004; Tal Peer <coredumb@gentoo.org> PECL-sqlite-1.0-r1.ebuild,
+ PECL-sqlite-1.0.2.ebuild:
+ Version bump, now uses the bundled lib.
13 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> metadata.xml:
add metadata.xml
diff --git a/dev-php/PECL-sqlite/Manifest b/dev-php/PECL-sqlite/Manifest
index a029838caa84..93416750ddc3 100644
--- a/dev-php/PECL-sqlite/Manifest
+++ b/dev-php/PECL-sqlite/Manifest
@@ -1,4 +1,8 @@
-MD5 fab5ec940d737fe806ebb2cd43c97223 files/digest-PECL-sqlite-1.0 59
-MD5 9f428dc3b33f64c23be31b15dad57bf0 ChangeLog 428
-MD5 34b376f52ca199fffb4e52b83169574a metadata.xml 156
MD5 1d2f2243086e9a41b03e010c0338ac1b PECL-sqlite-1.0.ebuild 848
+MD5 9f428dc3b33f64c23be31b15dad57bf0 ChangeLog 428
+MD5 90addd9e0cd39bebc1ca9eef0185f6fd metadata.xml 268
+MD5 a444b49bde8340145edde5bf0c76739c PECL-sqlite-1.0-r1.ebuild 742
+MD5 791ebbf104c09d35063a35a9dd7e3f14 PECL-sqlite-1.0.2.ebuild 633
+MD5 fab5ec940d737fe806ebb2cd43c97223 files/digest-PECL-sqlite-1.0 59
+MD5 fab5ec940d737fe806ebb2cd43c97223 files/digest-PECL-sqlite-1.0-r1 59
+MD5 a6651f8dd67550e61a12ecd993a37536 files/digest-PECL-sqlite-1.0.2 61
diff --git a/dev-php/PECL-sqlite/PECL-sqlite-1.0-r1.ebuild b/dev-php/PECL-sqlite/PECL-sqlite-1.0-r1.ebuild
new file mode 100644
index 000000000000..cff2d7881ccf
--- /dev/null
+++ b/dev-php/PECL-sqlite/PECL-sqlite-1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/PECL-sqlite-1.0-r1.ebuild,v 1.1 2004/01/24 17:14:34 coredumb Exp $
+
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_INI="yes"
+PHP_EXT_PECL_PKG="SQLite"
+
+inherit php-ext-pecl
+
+DEPEND="${DEPEND} >=dev-db/sqlite-2.8.5 !dev-php/sqlite-php"
+
+IUSE=""
+DESCRIPTION="PHP bindings for the SQLite database engine"
+HOMEPAGE="http://pear.php.net/SQLite"
+SLOT="0"
+LICENSE="PHP"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+src_compile() {
+ #use the external library, not the bundled one
+ myconf="${myconf} --with-sqlite=/usr"
+ php-ext-pecl_src_compile
+}
+
+src_install() {
+ php-ext-pecl_src_install
+ dodoc README TODO
+}
diff --git a/dev-php/PECL-sqlite/PECL-sqlite-1.0.2.ebuild b/dev-php/PECL-sqlite/PECL-sqlite-1.0.2.ebuild
new file mode 100644
index 000000000000..941f670323ef
--- /dev/null
+++ b/dev-php/PECL-sqlite/PECL-sqlite-1.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/PECL-sqlite-1.0.2.ebuild,v 1.1 2004/01/24 17:14:34 coredumb Exp $
+
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_INI="yes"
+PHP_EXT_PECL_PKG="SQLite"
+PHP_EXT_NAME="sqlite"
+
+inherit php-ext-pecl
+
+DEPEND="${DEPEND} !dev-php/sqlite-php"
+
+IUSE=""
+DESCRIPTION="PHP bindings for the SQLite database engine"
+HOMEPAGE="http://pear.php.net/SQLite"
+SLOT="0"
+LICENSE="PHP"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+src_compile() {
+ php-ext-pecl_src_compile
+}
+
+src_install() {
+ php-ext-pecl_src_install
+ dodoc README TODO
+}
diff --git a/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild b/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild
index 6cb88eb884fc..b3bfe40c5599 100644
--- a/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild
+++ b/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild,v 1.2 2003/07/26 16:01:11 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild,v 1.3 2004/01/24 17:14:34 coredumb Exp $
PHP_EXT_ZENDEXT="no"
PHP_EXT_NAME="sqlite"
diff --git a/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0-r1 b/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0-r1
new file mode 100644
index 000000000000..668759b24fc9
--- /dev/null
+++ b/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0-r1
@@ -0,0 +1 @@
+MD5 fabecdcdbeecd260cc05f90e4fcc79b8 SQLite-1.0.tgz 354024
diff --git a/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0.2 b/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0.2
new file mode 100644
index 000000000000..a9d341b8f083
--- /dev/null
+++ b/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0.2
@@ -0,0 +1 @@
+MD5 a6ddfe1136e35ad7feddc9ce9bfac991 SQLite-1.0.2.tgz 362412