summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-04-18 11:11:46 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-04-18 11:11:46 +0000
commit0537f0885f78afcce87d6420c726b96202a84b04 (patch)
tree9f6697c33c645af171566fc2045ec4f80d91bb97 /dev-python/4suite/4suite-1.0_beta1.ebuild
parentAdded gxine 0.4.3. Needs sparc and ppc64 test spidermonkey for their keywords. (diff)
downloadgentoo-2-0537f0885f78afcce87d6420c726b96202a84b04.tar.gz
gentoo-2-0537f0885f78afcce87d6420c726b96202a84b04.tar.bz2
gentoo-2-0537f0885f78afcce87d6420c726b96202a84b04.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-python/4suite/4suite-1.0_beta1.ebuild')
-rw-r--r--dev-python/4suite/4suite-1.0_beta1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/4suite/4suite-1.0_beta1.ebuild b/dev-python/4suite/4suite-1.0_beta1.ebuild
new file mode 100644
index 000000000000..0f3cc4c587a7
--- /dev/null
+++ b/dev-python/4suite/4suite-1.0_beta1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0_beta1.ebuild,v 1.1 2005/04/18 11:11:46 liquidx Exp $
+
+inherit distutils eutils
+
+MY_P=${P/_beta/b}
+MY_P=${MY_P/4s/4S}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Python tools for XML processing and object-databases."
+SRC_URI="mirror://sourceforge/foursuite/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.4suite.org/"
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/pyxml-0.8.3"
+
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc ~amd64"
+LICENSE="Apache-1.1"
+
+PYTHON_MODNAME="Ft"
+DOCS="docs/*.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/4S-1.0_a4.addrootopt-gentoo.diff
+ python setup.py config --prefix=/usr --docdir=/usr/share/doc/${P}
+}
+
+src_install() {
+ if use doc; then
+ distutils_src_install --with-docs
+ else
+ distutils_src_install
+ fi
+}