summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-25 23:13:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-25 23:13:27 +0000
commit2976aeeac40b097294d980751bddd52c730f2c3f (patch)
tree5f64536d7f5db571f5ab055b5edce56b0992e71e /dev-python/Babel
parentVersion bump. API break. (diff)
downloadgentoo-2-2976aeeac40b097294d980751bddd52c730f2c3f.tar.gz
gentoo-2-2976aeeac40b097294d980751bddd52c730f2c3f.tar.bz2
gentoo-2-2976aeeac40b097294d980751bddd52c730f2c3f.zip
Version bump.
(Portage version: 2.2.0_alpha28_p21/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-0.9.6.ebuild31
-rw-r--r--dev-python/Babel/ChangeLog10
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/Babel/Babel-0.9.6.ebuild b/dev-python/Babel/Babel-0.9.6.ebuild
new file mode 100644
index 000000000000..b18732416789
--- /dev/null
+++ b/dev-python/Babel/Babel-0.9.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Babel/Babel-0.9.6.ebuild,v 1.1 2011/03/25 23:13:27 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="A collection of tools for internationalizing Python applications"
+HOMEPAGE="http://babel.edgewall.org/ http://pypi.python.org/pypi/Babel"
+SRC_URI="http://ftp.edgewall.com/pub/babel/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/pytz
+ dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="babel"
+
+src_install() {
+ distutils_src_install
+ dohtml -r doc/* || die "dohtml failed"
+}
diff --git a/dev-python/Babel/ChangeLog b/dev-python/Babel/ChangeLog
index 393fa4431851..68f1b6c75031 100644
--- a/dev-python/Babel/ChangeLog
+++ b/dev-python/Babel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/Babel
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Babel/ChangeLog,v 1.32 2010/10/08 01:46:15 leio Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Babel/ChangeLog,v 1.33 2011/03/25 23:13:27 arfrever Exp $
+
+*Babel-0.9.6 (25 Mar 2011)
+
+ 25 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +Babel-0.9.6.ebuild:
+ Version bump.
08 Oct 2010; Mart Raudsepp <leio@gentoo.org> Babel-0.9.5.ebuild:
Add ~mips keyword.