summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2013-06-24 08:35:02 +0000
committerDavide Pesavento <pesa@gentoo.org>2013-06-24 08:35:02 +0000
commitbce441848ac85253df097d3fa3c66d476967da85 (patch)
treec08b94ca03f37daf4e99ac6fd01939063094fedf /dev-python/PyQt4
parentBump to 2.2.8, update 9999 to EAPI 5, bug #474552. Thanks to Nikoli. (diff)
downloadgentoo-2-bce441848ac85253df097d3fa3c66d476967da85.tar.gz
gentoo-2-bce441848ac85253df097d3fa3c66d476967da85.tar.bz2
gentoo-2-bce441848ac85253df097d3fa3c66d476967da85.zip
Add PYTHON_REQUIRED_USE. Remove old.
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog6
-rw-r--r--dev-python/PyQt4/PyQt4-4.10.1.ebuild3
-rw-r--r--dev-python/PyQt4/PyQt4-4.10.ebuild203
3 files changed, 7 insertions, 205 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index b1298c882961..f2eb46321bf7 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.223 2013/05/22 07:58:12 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.224 2013/06/24 08:35:02 pesa Exp $
+
+ 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
+ PyQt4-4.10.1.ebuild:
+ Add PYTHON_REQUIRED_USE. Remove old.
*PyQt4-4.10.1 (22 May 2013)
diff --git a/dev-python/PyQt4/PyQt4-4.10.1.ebuild b/dev-python/PyQt4/PyQt4-4.10.1.ebuild
index 51a7da772fc6..4f24a39216d0 100644
--- a/dev-python/PyQt4/PyQt4-4.10.1.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.10.1.ebuild,v 1.1 2013/05/22 07:58:12 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.10.1.ebuild,v 1.2 2013/06/24 08:35:02 pesa Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
@@ -24,6 +24,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-lin
IUSE="X dbus debug declarative doc examples help kde multimedia opengl phonon script scripttools sql svg webkit xmlpatterns"
REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
declarative? ( X )
help? ( X )
multimedia? ( X )
diff --git a/dev-python/PyQt4/PyQt4-4.10.ebuild b/dev-python/PyQt4/PyQt4-4.10.ebuild
deleted file mode 100644
index 9c7b2123e5bf..000000000000
--- a/dev-python/PyQt4/PyQt4-4.10.ebuild
+++ /dev/null
@@ -1,203 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.10.ebuild,v 1.1 2013/03/12 09:12:18 pesa Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
-
-inherit eutils qt4-r2 python-r1 toolchain-funcs
-
-DESCRIPTION="Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/ http://pypi.python.org/pypi/PyQt"
-
-if [[ ${PV} == *_pre* ]]; then
- MY_P="PyQt-x11-gpl-snapshot-${PV%_pre*}-${REVISION}"
- SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.gz"
-else
- MY_P="PyQt-x11-gpl-${PV}"
- SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-fi
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-IUSE="X dbus debug declarative doc examples help kde multimedia opengl phonon script scripttools sql svg webkit xmlpatterns"
-REQUIRED_USE="
- declarative? ( X )
- help? ( X )
- multimedia? ( X )
- opengl? ( X )
- phonon? ( X )
- scripttools? ( X script )
- sql? ( X )
- svg? ( X )
- webkit? ( X )
-"
-
-# Minimal supported version of Qt.
-QT_PV="4.8.0:4"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-python/sip-4.14.3:=[${PYTHON_USEDEP}]
- >=dev-qt/qtcore-${QT_PV}
- X? (
- >=dev-qt/qtgui-${QT_PV}[dbus?]
- >=dev-qt/qttest-${QT_PV}
- )
- dbus? (
- >=dev-python/dbus-python-0.80
- >=dev-qt/qtdbus-${QT_PV}
- )
- declarative? ( >=dev-qt/qtdeclarative-${QT_PV} )
- help? ( >=dev-qt/qthelp-${QT_PV} )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
- opengl? ( >=dev-qt/qtopengl-${QT_PV} )
- phonon? (
- kde? ( media-libs/phonon )
- !kde? ( || ( >=dev-qt/qtphonon-${QT_PV} media-libs/phonon ) )
- )
- script? ( >=dev-qt/qtscript-${QT_PV} )
- sql? ( >=dev-qt/qtsql-${QT_PV} )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- webkit? ( >=dev-qt/qtwebkit-${QT_PV} )
- xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
-"
-DEPEND="${RDEPEND}
- dbus? ( virtual/pkgconfig )
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- qt4-r2_src_prepare
-
- # Support qreal on arm architecture (bug 322349).
- use arm && epatch "${FILESDIR}/${PN}-4.7.3-qreal_float_support.patch"
-
- # Allow building against KDE's phonon (bug 433944 and others).
- sed -i \
- -e "s:VideoWidget()\":&, extra_include_dirs=[\"${EPREFIX}/usr/include/qt4/QtGui\"]:" \
- -e "s:^\s\+generate_code(\"phonon\":&, extra_include_dirs=[\"${EPREFIX}/usr/include/phonon\"]:" \
- configure.py || die
-
- if ! use dbus; then
- sed -i -e 's/^\(\s\+\)check_dbus()/\1pass/' configure.py || die
- fi
-
- python_copy_sources
-
- preparation() {
- if [[ ${EPYTHON} == python3.* ]]; then
- rm -fr pyuic/uic/port_v2
- else
- rm -fr pyuic/uic/port_v3
- fi
- }
- python_foreach_impl run_in_build_dir preparation
-}
-
-pyqt4_use_enable() {
- use $1 && echo --enable=${2:-Qt$(tr 'a-z' 'A-Z' <<< ${1:0:1})${1:1}}
-}
-
-src_configure() {
- configuration() {
- local myconf=(
- "${PYTHON}" configure.py
- --confirm-license
- --bindir="${EPREFIX}/usr/bin"
- --destdir="$(python_get_sitedir)"
- --sipdir="${EPREFIX}/usr/share/sip"
- --assume-shared
- --no-timestamp
- --qsci-api
- $(use debug && echo --debug)
- --enable=QtCore
- --enable=QtNetwork
- --enable=QtXml
- $(pyqt4_use_enable X QtDesigner) $(use X || echo --no-designer-plugin)
- $(pyqt4_use_enable X QtGui)
- $(pyqt4_use_enable X QtTest)
- $(pyqt4_use_enable dbus QtDBus)
- $(pyqt4_use_enable declarative)
- $(pyqt4_use_enable help)
- $(pyqt4_use_enable multimedia)
- $(pyqt4_use_enable opengl QtOpenGL)
- $(pyqt4_use_enable phonon phonon)
- $(pyqt4_use_enable script)
- $(pyqt4_use_enable scripttools QtScriptTools)
- $(pyqt4_use_enable sql)
- $(pyqt4_use_enable svg)
- $(pyqt4_use_enable webkit QtWebKit)
- $(pyqt4_use_enable xmlpatterns QtXmlPatterns)
- AR="$(tc-getAR) cqs"
- CC="$(tc-getCC)"
- CFLAGS="${CFLAGS}"
- CFLAGS_RELEASE=
- CXX="$(tc-getCXX)"
- CXXFLAGS="${CXXFLAGS}"
- CXXFLAGS_RELEASE=
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- LFLAGS="${LDFLAGS}"
- LFLAGS_RELEASE=
- RANLIB=
- STRIP=
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- local mod
- for mod in QtCore \
- $(use X && echo QtDesigner QtGui) \
- $(use dbus && echo QtDBus) \
- $(use declarative && echo QtDeclarative) \
- $(use opengl && echo QtOpenGL); do
- # Run eqmake4 inside the qpy subdirectories to respect
- # CC, CXX, CFLAGS, CXXFLAGS, LDFLAGS and avoid stripping.
- pushd qpy/${mod} > /dev/null || return
- eqmake4 $(ls w_qpy*.pro)
- popd > /dev/null || return
-
- # Fix insecure runpaths.
- sed -i -e "/^LFLAGS\s*=/ s:-Wl,-rpath,${BUILD_DIR}/qpy/${mod}::" \
- ${mod}/Makefile || die "failed to fix rpath for ${mod}"
- done
-
- # Avoid stripping of libpythonplugin.so.
- if use X; then
- pushd designer > /dev/null || return
- eqmake4 python.pro
- popd > /dev/null || return
- fi
- }
- python_parallel_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- # INSTALL_ROOT is used by designer/Makefile, other Makefiles use DESTDIR.
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
- mv "${ED}"/usr/bin/pyuic4{,-${EPYTHON}} || die
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- dosym python-exec /usr/bin/pyuic4
- dodoc NEWS THANKS
-
- if use doc; then
- dohtml -r doc/html/*
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}