summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-02-22 14:11:45 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-02-22 14:11:45 +0000
commitea0f810f6a3af37a3cebfd5c7e1f7758cb160ba6 (patch)
tree7f78e40174263f4118b6239dc1c8a0eb060f1a70 /dev-python/PyQt
parentInitial commit of cvsutils (diff)
downloadgentoo-2-ea0f810f6a3af37a3cebfd5c7e1f7758cb160ba6.tar.gz
gentoo-2-ea0f810f6a3af37a3cebfd5c7e1f7758cb160ba6.tar.bz2
gentoo-2-ea0f810f6a3af37a3cebfd5c7e1f7758cb160ba6.zip
Clean up.
(Portage version: 2.0.54)
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/ChangeLog10
-rw-r--r--dev-python/PyQt/PyQt-3.11.ebuild51
-rw-r--r--dev-python/PyQt/PyQt-3.12.ebuild48
-rw-r--r--dev-python/PyQt/PyQt-3.13-r1.ebuild62
-rw-r--r--dev-python/PyQt/PyQt-3.13-r2.ebuild6
-rw-r--r--dev-python/PyQt/PyQt-3.13.ebuild60
-rw-r--r--dev-python/PyQt/PyQt-3.14.1-r1.ebuild4
-rw-r--r--dev-python/PyQt/PyQt-3.14.1.ebuild62
-rw-r--r--dev-python/PyQt/PyQt-3.14.ebuild62
-rw-r--r--dev-python/PyQt/PyQt-3.15.1.ebuild4
-rw-r--r--dev-python/PyQt/PyQt-3.15.ebuild62
-rw-r--r--dev-python/PyQt/PyQt-3.8.1.ebuild66
-rw-r--r--dev-python/PyQt/files/PyQt-3.8.1-qt-3.3.patch14
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.111
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.121
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.131
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.13-r11
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.141
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.14.11
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.151
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.8.11
-rw-r--r--dev-python/PyQt/files/license-3.8.1.diff33
22 files changed, 16 insertions, 536 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index 6bc6d8608198..0d4a03510e23 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.68 2006/02/09 00:14:17 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.69 2006/02/22 14:10:35 carlo Exp $
+
+ 22 Feb 2006; Carsten Lohrke <carlo@gentoo.org>
+ -files/PyQt-3.8.1-qt-3.3.patch, -files/license-3.8.1.diff,
+ -PyQt-3.8.1.ebuild, -PyQt-3.11.ebuild, -PyQt-3.12.ebuild,
+ -PyQt-3.13.ebuild, -PyQt-3.13-r1.ebuild, PyQt-3.13-r2.ebuild,
+ -PyQt-3.14.ebuild, -PyQt-3.14.1.ebuild, PyQt-3.14.1-r1.ebuild,
+ -PyQt-3.15.ebuild, PyQt-3.15.1.ebuild:
+ Clean up.
24 Jan 2006; Markus Rothe <corsair@gentoo.org> PyQt-3.14.1-r1.ebuild:
Stable on ppc64
diff --git a/dev-python/PyQt/PyQt-3.11.ebuild b/dev-python/PyQt/PyQt-3.11.ebuild
deleted file mode 100644
index 1b93642e76b5..000000000000
--- a/dev-python/PyQt/PyQt-3.11.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.11.ebuild,v 1.8 2005/02/08 05:46:02 eradicator Exp $
-
-inherit distutils
-
-IUSE=""
-MY_P="PyQt-x11-gpl-${PV}"
-S="${WORKDIR}/${MY_P}"
-DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ppc ~sparc ~alpha amd64"
-
-RDEPEND="virtual/libc
- x11-libs/qt
- dev-lang/python
- >=dev-python/sip-3.10.1
- <=dev-python/qscintilla-1.54"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_compile() {
- distutils_python_version
-
- # standard qt sandbox problem workaround
- [ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
- dodir /usr/lib/python${PYVER}/site-packages /usr/include/python${PYVER} /usr/bin /usr/share/sip
- cd ${S}
- sed -i -e "s/ check_license()/# check_license()/" configure.py
- python configure.py \
- -d ${D}usr/lib/python${PYVER}/site-packages \
- -b ${D}usr/bin \
- -v ${D}usr/share/sip \
- -c
- make || die
-}
-
-src_install() {
- make install || die
- dodoc ChangeLog LICENSE NEWS README README.Linux README.SunOS THANKS
- dodir /usr/share/doc/${P}/
- mv ${D}/usr/share/doc/* ${D}/usr/share/doc/${P}/
- insinto /usr/share/sip
- doins ${S}/sip/*
- echo "/${D//\//\\/}/s//\//" > fixpaths.sed
- sed -i -f fixpaths.sed ${D}usr/lib/python${PYVER}/site-packages/pyqtconfig.py
-}
diff --git a/dev-python/PyQt/PyQt-3.12.ebuild b/dev-python/PyQt/PyQt-3.12.ebuild
deleted file mode 100644
index 56b023c02fff..000000000000
--- a/dev-python/PyQt/PyQt-3.12.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.12.ebuild,v 1.10 2005/02/08 05:46:02 eradicator Exp $
-
-inherit distutils
-
-IUSE="doc"
-
-MY_P="PyQt-x11-gpl-${PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-
-HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc -alpha amd64"
-
-RDEPEND="virtual/libc
- x11-libs/qt
- dev-lang/python
- >=dev-python/sip-3.10.2
- <=dev-python/qscintilla-1.60"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
- sed -i -e "s/ check_license()/# check_license()/" configure.py
- python configure.py \
- -d /usr/lib/python${PYVER}/site-packages \
- -b /usr/bin \
- -v /usr/share/sip \
- -c
- emake || die
-}
-
-src_install() {
- einstall DESTDIR=${D} || die
- dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
- use doc && ( dohtml doc/PyQt.html
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* ${D}/usr/share/doc/${PF}/examples )
-}
diff --git a/dev-python/PyQt/PyQt-3.13-r1.ebuild b/dev-python/PyQt/PyQt-3.13-r1.ebuild
deleted file mode 100644
index fb8da9817fd2..000000000000
--- a/dev-python/PyQt/PyQt-3.13-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.13-r1.ebuild,v 1.1 2005/02/20 16:11:15 carlo Exp $
-
-inherit distutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-#SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
-#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/PyQt/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc -alpha ~amd64 ~ppc64"
-IUSE="debug doc"
-
-RDEPEND="virtual/libc
- x11-libs/qt
- dev-lang/python
- >=dev-python/sip-3.10.2
- <dev-python/qscintilla-1.6"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s: check_license():# check_license():" ${S}/configure.py
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin \
- -v /usr/share/sip -n /usr/include -o /usr/$(get_libdir)"
- use debug && myconf="${myconf} -u"
- has distcc ${FEATURES} || myconf="${myconf} -c"
-
- if [ "$(echo $(free -m | grep Mem) | cut -d' ' -f2)" -lt "257" ] ; then
- echo ""
- einfo "Low on memory?! Use distcc or get a coffee. :)"
- echo ""
- fi
-
- python configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
- if use doc ; then
- dohtml doc/PyQt.html
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/PyQt/PyQt-3.13-r2.ebuild b/dev-python/PyQt/PyQt-3.13-r2.ebuild
index 4046d77b4a9e..0c60ef1ae5aa 100644
--- a/dev-python/PyQt/PyQt-3.13-r2.ebuild
+++ b/dev-python/PyQt/PyQt-3.13-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.13-r2.ebuild,v 1.1 2005/12/09 22:07:41 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.13-r2.ebuild,v 1.2 2006/02/22 14:10:35 carlo Exp $
inherit distutils eutils
@@ -18,7 +18,7 @@ IUSE="debug doc examples"
RDEPEND="=x11-libs/qt-3*
>=dev-python/sip-3.10.2
- <dev-python/qscintilla-1.6"
+ dev-python/qscintilla"
DEPEND="${RDEPEND}
sys-devel/libtool"
diff --git a/dev-python/PyQt/PyQt-3.13.ebuild b/dev-python/PyQt/PyQt-3.13.ebuild
deleted file mode 100644
index 3701b94c51e2..000000000000
--- a/dev-python/PyQt/PyQt-3.13.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.13.ebuild,v 1.10 2005/11/26 00:36:43 tgall Exp $
-
-inherit distutils
-
-MY_P="PyQt-x11-gpl-${PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc -alpha amd64 ppc64"
-IUSE="debug doc"
-
-RDEPEND="virtual/libc
- x11-libs/qt
- dev-lang/python
- >=dev-python/sip-3.10.2
- <=dev-python/qscintilla-1.61"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s/ check_license()/# check_license()/" ${S}/configure.py
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin -v /usr/share/sip"
- use debug && myconf="${myconf} -u"
- has distcc ${FEATURES} || myconf="${myconf} -c"
-
- if [ "$(echo $(free -m | grep Mem) | cut -d' ' -f2)" -lt "257" ] ; then
- echo ""
- einfo "Low on memory?! Use distcc or get a coffee. :)"
- echo ""
- fi
-
- python configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
- if use doc ; then
- dohtml doc/PyQt.html
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/PyQt/PyQt-3.14.1-r1.ebuild b/dev-python/PyQt/PyQt-3.14.1-r1.ebuild
index d75c31391978..10c0fa829468 100644
--- a/dev-python/PyQt/PyQt-3.14.1-r1.ebuild
+++ b/dev-python/PyQt/PyQt-3.14.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.14.1-r1.ebuild,v 1.8 2006/01/24 18:36:59 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.14.1-r1.ebuild,v 1.9 2006/02/22 14:10:35 carlo Exp $
inherit distutils eutils
@@ -18,7 +18,7 @@ IUSE="debug doc examples"
RDEPEND="x11-libs/qt
~dev-python/sip-4.2.1
- <dev-python/qscintilla-1.6"
+ dev-python/qscintilla"
DEPEND="${RDEPEND}
sys-devel/libtool"
diff --git a/dev-python/PyQt/PyQt-3.14.1.ebuild b/dev-python/PyQt/PyQt-3.14.1.ebuild
deleted file mode 100644
index 66161ea19d62..000000000000
--- a/dev-python/PyQt/PyQt-3.14.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.14.1.ebuild,v 1.2 2005/03/29 20:06:44 kloeri Exp $
-
-inherit distutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-#SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
-#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/PyQt/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ppc64"
-IUSE="debug doc"
-
-RDEPEND="virtual/libc
- x11-libs/qt
- dev-lang/python
- >=dev-python/sip-4.2
- <dev-python/qscintilla-1.6"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s: check_license():# check_license():" ${S}/configure.py
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin \
- -v /usr/share/sip -n /usr/include -o /usr/$(get_libdir)"
- use debug && myconf="${myconf} -u"
- has distcc ${FEATURES} || myconf="${myconf} -c"
-
- if [ "$(echo $(free -m | grep Mem) | cut -d' ' -f2)" -lt "257" ] ; then
- echo ""
- einfo "Low on memory?! Use distcc or get a coffee. :)"
- echo ""
- fi
-
- python configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
- if use doc ; then
- dohtml doc/PyQt.html
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/PyQt/PyQt-3.14.ebuild b/dev-python/PyQt/PyQt-3.14.ebuild
deleted file mode 100644
index a3b996dc3ea6..000000000000
--- a/dev-python/PyQt/PyQt-3.14.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.14.ebuild,v 1.2 2005/03/29 20:06:44 kloeri Exp $
-
-inherit distutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-#SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
-#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/PyQt/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ppc64"
-IUSE="debug doc"
-
-RDEPEND="virtual/libc
- x11-libs/qt
- dev-lang/python
- >=dev-python/sip-4.2
- <dev-python/qscintilla-1.6"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s: check_license():# check_license():" ${S}/configure.py
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin \
- -v /usr/share/sip -n /usr/include -o /usr/$(get_libdir)"
- use debug && myconf="${myconf} -u"
- has distcc ${FEATURES} || myconf="${myconf} -c"
-
- if [ "$(echo $(free -m | grep Mem) | cut -d' ' -f2)" -lt "257" ] ; then
- echo ""
- einfo "Low on memory?! Use distcc or get a coffee. :)"
- echo ""
- fi
-
- python configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
- if use doc ; then
- dohtml doc/PyQt.html
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/PyQt/PyQt-3.15.1.ebuild b/dev-python/PyQt/PyQt-3.15.1.ebuild
index 478d8fefb8f0..cd61d56463af 100644
--- a/dev-python/PyQt/PyQt-3.15.1.ebuild
+++ b/dev-python/PyQt/PyQt-3.15.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.15.1.ebuild,v 1.2 2006/01/20 17:40:24 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.15.1.ebuild,v 1.3 2006/02/22 14:10:35 carlo Exp $
inherit distutils
@@ -20,7 +20,7 @@ IUSE="debug doc examples"
RDEPEND="=x11-libs/qt-3*
>=dev-python/sip-4.3
- <dev-python/qscintilla-1.10"
+ dev-python/qscintilla"
DEPEND="${RDEPEND}
sys-devel/libtool"
diff --git a/dev-python/PyQt/PyQt-3.15.ebuild b/dev-python/PyQt/PyQt-3.15.ebuild
deleted file mode 100644
index a5c9010965ef..000000000000
--- a/dev-python/PyQt/PyQt-3.15.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.15.ebuild,v 1.3 2005/10/11 12:29:21 chrb Exp $
-
-inherit distutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-#SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
-#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/PyQt/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ppc64"
-IUSE="debug doc"
-
-RDEPEND="virtual/libc
- x11-libs/qt
- dev-lang/python
- >=dev-python/sip-4.2
- dev-python/qscintilla"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s: check_license():# check_license():" ${S}/configure.py
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin \
- -v /usr/share/sip"
- use debug && myconf="${myconf} -u"
- has distcc ${FEATURES} || myconf="${myconf} -c"
-
- if [ "$(echo $(free -m | grep Mem) | cut -d' ' -f2)" -lt "257" ] ; then
- echo ""
- einfo "Low on memory?! Use distcc or get a coffee. :)"
- echo ""
- fi
-
- python configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
- if use doc ; then
- dohtml doc/PyQt.html
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/PyQt/PyQt-3.8.1.ebuild b/dev-python/PyQt/PyQt-3.8.1.ebuild
deleted file mode 100644
index 56a47e47ba03..000000000000
--- a/dev-python/PyQt/PyQt-3.8.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.8.1.ebuild,v 1.16 2006/01/14 20:46:44 yoswink Exp $
-
-inherit distutils eutils
-
-S="${WORKDIR}/PyQt-x11-gpl-${PV}"
-
-DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
-SRC_URI="mirror://gentoo/PyQt-x11-gpl-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="ppc"
-IUSE=""
-
-PV_MAJOR=${PV/.*/}
-PV_MINOR=${PV#${PV_MAJOR}.}
-PV_MINOR=${PV_MINOR/.*}
-
-RDEPEND="virtual/libc
- x11-libs/qt
- dev-lang/python
- =dev-python/sip-${PV_MAJOR}.${PV_MINOR}*
- >=dev-python/qscintilla-1.53"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_unpack() {
- unpack PyQt-x11-gpl-${PV}.tar.gz
- cd ${S}
- epatch $FILESDIR/license-${PV}.diff
-}
-
-src_compile() {
- distutils_python_version
-
- # fix qt-3.3 compile problem
- if has_version '=x11-libs/qt-3.3*' ; then
- epatch "${FILESDIR}/${P}-qt-3.3.patch"
- fi
-
- # standard qt sandbox problem workaround
- [ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
- dodir /usr/lib/python${PYVER}/site-packages
- dodir /usr/include/python${PYVER}
- python build.py \
- -d ${D}/usr/lib/python${PYVER}/site-packages \
- -e /usr/include/python${PYVER} \
- -b ${D}/usr/bin \
- -l qt-mt -c
-}
-
-src_install() {
- make || die
- distutils_python_version
- dodir /usr/lib/python${PYVER}/site-packages
- make DESTDIR=${D} install || die
- dodoc README.Linux NEWS LICENSE README ChangeLog THANKS
- dodir /usr/share/doc/${P}/
- # I found out this location from the redhat rpm
- insinto /usr/share/sip/qt
- doins ${S}/sip/*
-}
diff --git a/dev-python/PyQt/files/PyQt-3.8.1-qt-3.3.patch b/dev-python/PyQt/files/PyQt-3.8.1-qt-3.3.patch
deleted file mode 100644
index 5baec9bd6bf4..000000000000
--- a/dev-python/PyQt/files/PyQt-3.8.1-qt-3.3.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- PyQt-x11-gpl-3.8.1/sip/qtable.sip~ 2004-02-25 23:51:33.880257192 +0100
-+++ PyQt-x11-gpl-3.8.1/sip/qtable.sip 2004-02-25 23:51:42.716913816 +0100
-@@ -149,11 +149,6 @@
-
- virtual int rtti() const;
- %End
--
--protected:
--%If (Qt_3_2_0 -)
-- QString content() const;
--%End
- };
-
-
diff --git a/dev-python/PyQt/files/digest-PyQt-3.11 b/dev-python/PyQt/files/digest-PyQt-3.11
deleted file mode 100644
index bc7b98e81f22..000000000000
--- a/dev-python/PyQt/files/digest-PyQt-3.11
+++ /dev/null
@@ -1 +0,0 @@
-MD5 78d0ef29f57d7efd1d87f9a24fc25f1e PyQt-x11-gpl-3.11.tar.gz 757652
diff --git a/dev-python/PyQt/files/digest-PyQt-3.12 b/dev-python/PyQt/files/digest-PyQt-3.12
deleted file mode 100644
index f8c624feeda4..000000000000
--- a/dev-python/PyQt/files/digest-PyQt-3.12
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0869e68c24ee6e46ae74d3244e7ec299 PyQt-x11-gpl-3.12.tar.gz 760165
diff --git a/dev-python/PyQt/files/digest-PyQt-3.13 b/dev-python/PyQt/files/digest-PyQt-3.13
deleted file mode 100644
index c64660b67669..000000000000
--- a/dev-python/PyQt/files/digest-PyQt-3.13
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a4145b39742a4d9df9b6bf06495f75f5 PyQt-x11-gpl-3.13.tar.gz 763066
diff --git a/dev-python/PyQt/files/digest-PyQt-3.13-r1 b/dev-python/PyQt/files/digest-PyQt-3.13-r1
deleted file mode 100644
index c64660b67669..000000000000
--- a/dev-python/PyQt/files/digest-PyQt-3.13-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a4145b39742a4d9df9b6bf06495f75f5 PyQt-x11-gpl-3.13.tar.gz 763066
diff --git a/dev-python/PyQt/files/digest-PyQt-3.14 b/dev-python/PyQt/files/digest-PyQt-3.14
deleted file mode 100644
index 7b817feb77a1..000000000000
--- a/dev-python/PyQt/files/digest-PyQt-3.14
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a63f0a9e2bd84a110ecbaf6cdf1d956f PyQt-x11-gpl-3.14.tar.gz 782085
diff --git a/dev-python/PyQt/files/digest-PyQt-3.14.1 b/dev-python/PyQt/files/digest-PyQt-3.14.1
deleted file mode 100644
index a7791cbd39b4..000000000000
--- a/dev-python/PyQt/files/digest-PyQt-3.14.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 bf6d939ec77e48a2db7561e7bac61d19 PyQt-x11-gpl-3.14.1.tar.gz 782274
diff --git a/dev-python/PyQt/files/digest-PyQt-3.15 b/dev-python/PyQt/files/digest-PyQt-3.15
deleted file mode 100644
index 90cc1dd2c9dd..000000000000
--- a/dev-python/PyQt/files/digest-PyQt-3.15
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8e70fac4f403fb759b537008170ff446 PyQt-x11-gpl-3.15.tar.gz 789772
diff --git a/dev-python/PyQt/files/digest-PyQt-3.8.1 b/dev-python/PyQt/files/digest-PyQt-3.8.1
deleted file mode 100644
index ae65b19a75b0..000000000000
--- a/dev-python/PyQt/files/digest-PyQt-3.8.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 bde37288aea521b9981cc8a193707932 PyQt-x11-gpl-3.8.1.tar.gz 743691
diff --git a/dev-python/PyQt/files/license-3.8.1.diff b/dev-python/PyQt/files/license-3.8.1.diff
deleted file mode 100644
index bce72604c1f0..000000000000
--- a/dev-python/PyQt/files/license-3.8.1.diff
+++ /dev/null
@@ -1,33 +0,0 @@
---- build.py.orig 2003-09-19 03:04:28.000000000 +0200
-+++ build.py 2003-09-19 03:05:25.000000000 +0200
-@@ -710,30 +710,6 @@
- licType = "GPL"
- licname = "GNU General Public License"
-
-- inform("This is the %s version of PyQt and is licensed under the %s." % (licType,licname),0)
--
-- print
-- print "Type 'L' to view the license."
-- print "Type 'yes' to accept the terms of the license."
-- print "Type 'no' to decline the terms of the license."
-- print
--
-- while 1:
-- try:
-- resp = raw_input("Do you accept the terms of the license? ")
-- except:
-- resp = ""
--
-- resp = string.lower(string.strip(resp))
--
-- if resp == "yes":
-- break
--
-- if resp == "no":
-- sys.exit(0)
--
-- if resp == "l":
-- os.system("more LICENSE")
-
- inform("Building the %s version of PyQt 3.8.1 for Python %s on %s." % (licType,pyFullVers,sys.platform))
-