summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-03-27 21:44:11 +0000
committerBen de Groot <yngwin@gentoo.org>2009-03-27 21:44:11 +0000
commiteedb834da5406b8f7ad64dfd6db37039272883d5 (patch)
tree8f1487af83d12979f4e30d60b2cd7484b20b5cb3 /dev-python/PyQt
parentStable for HPPA (bug #262736). (diff)
downloadgentoo-2-eedb834da5406b8f7ad64dfd6db37039272883d5.tar.gz
gentoo-2-eedb834da5406b8f7ad64dfd6db37039272883d5.tar.bz2
gentoo-2-eedb834da5406b8f7ad64dfd6db37039272883d5.zip
Remove older versions
(Portage version: 2.2_rc27/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/ChangeLog6
-rw-r--r--dev-python/PyQt/PyQt-3.17.3.ebuild56
-rw-r--r--dev-python/PyQt/PyQt-3.17.4.ebuild56
3 files changed, 5 insertions, 113 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index 2b37697748a7..8c1de3cd7f77 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.113 2009/02/20 17:49:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.114 2009/03/27 21:44:11 yngwin Exp $
+
+ 27 Mar 2009; Ben de Groot <yngwin@gentoo.org> -PyQt-3.17.3.ebuild,
+ -PyQt-3.17.4.ebuild:
+ Remove older versions which are also hardmasked
20 Feb 2009; Jeroen Roovers <jer@gentoo.org> PyQt-3.17.6.ebuild:
Stable for HPPA (bug #248083).
diff --git a/dev-python/PyQt/PyQt-3.17.3.ebuild b/dev-python/PyQt/PyQt-3.17.3.ebuild
deleted file mode 100644
index 024a39e99251..000000000000
--- a/dev-python/PyQt/PyQt-3.17.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.17.3.ebuild,v 1.9 2008/05/13 08:52:27 hawking Exp $
-
-inherit distutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt3/GPL/${MY_P}.tar.gz"
-#SRC_URI="http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt3/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ~hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug doc examples"
-
-RDEPEND="=x11-libs/qt-3*
- >=dev-python/sip-4.7
- x11-libs/qscintilla"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages \
- -b /usr/bin \
- -v /usr/share/sip \
- -n /usr/include \
- -o /usr/$(get_libdir) \
- -w -y qt-mt"
- use debug && myconf="${myconf} -u"
-
- python configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc ChangeLog NEWS README README.Linux THANKS
- use doc && dohtml doc/PyQt.html
- if use examples ; then
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/PyQt/PyQt-3.17.4.ebuild b/dev-python/PyQt/PyQt-3.17.4.ebuild
deleted file mode 100644
index 0d454d76464b..000000000000
--- a/dev-python/PyQt/PyQt-3.17.4.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.17.4.ebuild,v 1.7 2008/05/13 08:52:27 hawking Exp $
-
-inherit distutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt3/GPL/${MY_P}.tar.gz"
-#SRC_URI="http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt3/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ~hppa ia64 ~ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug doc examples"
-
-RDEPEND="=x11-libs/qt-3*
- >=dev-python/sip-4.7.3
- x11-libs/qscintilla"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages \
- -b /usr/bin \
- -v /usr/share/sip \
- -n /usr/include \
- -o /usr/$(get_libdir) \
- -w -y qt-mt"
- use debug && myconf="${myconf} -u"
-
- python configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc ChangeLog NEWS README THANKS
- use doc && dohtml doc/PyQt.html
- if use examples ; then
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
- fi
-}