summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-03-13 11:44:34 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-03-13 11:44:34 +0000
commit55719f5ccacdeb506c647b6abba36179c585dfde (patch)
tree370ad955ce99af16091dd7fd2076090ee1978f94 /dev-python/PyQtMobility
parentStable for HPPA (bug #407549). (diff)
downloadgentoo-2-55719f5ccacdeb506c647b6abba36179c585dfde.tar.gz
gentoo-2-55719f5ccacdeb506c647b6abba36179c585dfde.tar.bz2
gentoo-2-55719f5ccacdeb506c647b6abba36179c585dfde.zip
Initial commit of PyQtMobility, moved from qt overlay. Ebuild by me.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQtMobility')
-rw-r--r--dev-python/PyQtMobility/ChangeLog10
-rw-r--r--dev-python/PyQtMobility/PyQtMobility-1.0.1.ebuild91
-rw-r--r--dev-python/PyQtMobility/metadata.xml27
3 files changed, 128 insertions, 0 deletions
diff --git a/dev-python/PyQtMobility/ChangeLog b/dev-python/PyQtMobility/ChangeLog
new file mode 100644
index 000000000000..af94efe54146
--- /dev/null
+++ b/dev-python/PyQtMobility/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/PyQtMobility
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQtMobility/ChangeLog,v 1.1 2012/03/13 11:44:34 pesa Exp $
+
+*PyQtMobility-1.0.1 (13 Mar 2012)
+
+ 13 Mar 2012; Davide Pesavento <pesa@gentoo.org> +PyQtMobility-1.0.1.ebuild,
+ +metadata.xml:
+ Initial commit of PyQtMobility, moved from qt overlay. Ebuild by me.
+
diff --git a/dev-python/PyQtMobility/PyQtMobility-1.0.1.ebuild b/dev-python/PyQtMobility/PyQtMobility-1.0.1.ebuild
new file mode 100644
index 000000000000..8c8baa5b3fbc
--- /dev/null
+++ b/dev-python/PyQtMobility/PyQtMobility-1.0.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQtMobility/PyQtMobility-1.0.1.ebuild,v 1.1 2012/03/13 11:44:34 pesa Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
+
+inherit python
+
+MY_P=${PN}-gpl-${PV}
+
+DESCRIPTION="Python bindings for Nokia's QtMobility libraries"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqtmobility/intro"
+SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 GPL-3 )"
+KEYWORDS="~amd64"
+
+PYQTM_MODULES="contacts feedback gallery location messaging multimedia organizer
+ publishsubscribe sensors serviceframework systeminfo versit"
+IUSE="debug ${PYQTM_MODULES}"
+
+REQUIRED_USE="
+ || ( ${PYQTM_MODULES//+} )
+ versit? ( contacts )
+"
+
+QTM_USE_DEPS=
+for mod in ${PYQTM_MODULES//+}; do
+ QTM_USE_DEPS+="${mod}?,"
+done
+unset mod
+
+DEPEND="
+ >=dev-python/sip-4.12.2
+ >=dev-python/PyQt4-4.8.4[X]
+ >=x11-libs/qt-mobility-1.2.0[${QTM_USE_DEPS%,}]
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Disable pre-stripping of modules
+ sed -i -e '/SIPModuleMakefile/s|$|strip=0,|' configure.py || die
+
+ python_src_prepare
+}
+
+pyqtm_use_enable() {
+ use $1 && echo --enable=${2:-Qt$(echo ${1:0:1} | tr '[:lower:]' '[:upper:]')${1:1}}
+}
+
+src_configure() {
+ configuration() {
+ local myconf=("$(PYTHON)"
+ configure.py
+ --destdir="${EPREFIX}$(python_get_sitedir)"
+ --sipdir="${EPREFIX}/usr/share/sip"
+ $(use debug && echo --debug)
+ $(pyqtm_use_enable contacts)
+ $(pyqtm_use_enable feedback)
+ $(pyqtm_use_enable gallery)
+ $(pyqtm_use_enable location)
+ $(pyqtm_use_enable messaging)
+ $(pyqtm_use_enable multimedia QtMultimediaKit)
+ $(pyqtm_use_enable organizer)
+ $(pyqtm_use_enable publishsubscribe QtPublishSubscribe)
+ $(pyqtm_use_enable sensors)
+ $(pyqtm_use_enable serviceframework QtServiceFramework)
+ $(pyqtm_use_enable systeminfo QtSystemInfo)
+ $(pyqtm_use_enable versit)
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}"
+ }
+ python_execute_function -s configuration
+}
+
+pkg_postinst() {
+ python_mod_optimize QtMobility
+}
+
+pkg_postrm() {
+ python_mod_cleanup QtMobility
+}
diff --git a/dev-python/PyQtMobility/metadata.xml b/dev-python/PyQtMobility/metadata.xml
new file mode 100644
index 000000000000..5fecc85e4c00
--- /dev/null
+++ b/dev-python/PyQtMobility/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <herd>python</herd>
+ <use>
+ <flag name="contacts">Build bindings for the QtContacts module</flag>
+ <flag name="feedback">Build bindings for the QtFeedback module</flag>
+ <flag name="gallery">Build bindings for the QtGallery module</flag>
+ <flag name="location">Build bindings for the QtLocation module</flag>
+ <flag name="messaging">Build bindings for the QtMessaging module</flag>
+ <flag name="multimedia">Build bindings for the QtMultimediaKit module</flag>
+ <flag name="organizer">Build bindings for the QtOrganizer module</flag>
+ <flag name="publishsubscribe">Build bindings for the QtPublishSubscribe module</flag>
+ <flag name="sensors">Build bindings for the QtSensors module</flag>
+ <flag name="serviceframework">Build bindings for the QtServiceFramework module</flag>
+ <flag name="systeminfo">Build bindings for the QtSystemInfo module</flag>
+ <flag name="versit">Build bindings for the QtVersit module</flag>
+ </use>
+ <upstream>
+ <maintainer status="active">
+ <email>phil@riverbankcomputing.com</email>
+ <name>Phil Thompson</name>
+ </maintainer>
+ <bugs-to>mailto:pyqt@riverbankcomputing.com</bugs-to>
+ </upstream>
+</pkgmetadata>