summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-02-15 08:56:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-02-15 08:56:54 +0000
commit035bea85266db1147384c334a33df3d37a2bc1ea (patch)
tree0f542957701920da9a561a925a6a04807effef08 /dev-python/alembic/alembic-0.6.3.ebuild
parentPunt useless --disable-silent-rules which is implied by eapi5. Use get_udevdi... (diff)
downloadgentoo-2-035bea85266db1147384c334a33df3d37a2bc1ea.tar.gz
gentoo-2-035bea85266db1147384c334a33df3d37a2bc1ea.tar.bz2
gentoo-2-035bea85266db1147384c334a33df3d37a2bc1ea.zip
Bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/alembic/alembic-0.6.3.ebuild')
-rw-r--r--dev-python/alembic/alembic-0.6.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/alembic/alembic-0.6.3.ebuild b/dev-python/alembic/alembic-0.6.3.ebuild
new file mode 100644
index 000000000000..f2424d9a0a2b
--- /dev/null
+++ b/dev-python/alembic/alembic-0.6.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/alembic/alembic-0.6.3.ebuild,v 1.1 2014/02/15 08:56:54 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+RESTRICT="test" # 501362
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+RDEPEND=">=dev-python/sqlalchemy-0.7.9
+ dev-python/mako
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ cp -r test.cfg tests "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ if [[ ${EPYTHON} == python3* ]]; then
+ 2to3 -w -n tests || die
+ fi
+ nosetests || die "Testing failed with ${EPYTHON}"
+}