summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-11-02 21:31:36 +0000
committerMichał Górny <mgorny@gentoo.org>2012-11-02 21:31:36 +0000
commit3e9da61d0cc4389b960558896bd7ed5df7efdf1d (patch)
tree48a2c82261211d4741b696467168a7a7269da7a1 /dev-python/argparse
parentVersion bunp to add fixes to support /etc/portage/make.conf and (diff)
downloadgentoo-2-3e9da61d0cc4389b960558896bd7ed5df7efdf1d.tar.gz
gentoo-2-3e9da61d0cc4389b960558896bd7ed5df7efdf1d.tar.bz2
gentoo-2-3e9da61d0cc4389b960558896bd7ed5df7efdf1d.zip
Re-enable all Python implementations but warn if the package is not useful, requesting people to depclean it.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/argparse')
-rw-r--r--dev-python/argparse/ChangeLog6
-rw-r--r--dev-python/argparse/argparse-1.2.1-r1.ebuild38
2 files changed, 40 insertions, 4 deletions
diff --git a/dev-python/argparse/ChangeLog b/dev-python/argparse/ChangeLog
index 35c1477e1016..e7bb94cac48f 100644
--- a/dev-python/argparse/ChangeLog
+++ b/dev-python/argparse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/argparse
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/argparse/ChangeLog,v 1.33 2012/10/29 13:50:04 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/argparse/ChangeLog,v 1.34 2012/11/02 21:31:36 mgorny Exp $
+
+ 02 Nov 2012; Michał Górny <mgorny@gentoo.org> argparse-1.2.1-r1.ebuild:
+ Re-enable all Python implementations but warn if the package is not useful,
+ requesting people to depclean it.
*argparse-1.2.1-r1 (29 Oct 2012)
diff --git a/dev-python/argparse/argparse-1.2.1-r1.ebuild b/dev-python/argparse/argparse-1.2.1-r1.ebuild
index be412a6690da..bbee3c1acefd 100644
--- a/dev-python/argparse/argparse-1.2.1-r1.ebuild
+++ b/dev-python/argparse/argparse-1.2.1-r1.ebuild
@@ -1,10 +1,18 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/argparse/argparse-1.2.1-r1.ebuild,v 1.1 2012/10/29 13:50:04 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/argparse/argparse-1.2.1-r1.ebuild,v 1.2 2012/11/02 21:31:36 mgorny Exp $
EAPI=4
-# Newer versions provide built-in argparse.
-PYTHON_COMPAT=( python2_5 python2_6 python3_1 jython2_5 )
+PYTHON_COMPAT_REAL=(
+ # actual targets
+ python{2_5,2_6,3_1} jython2_5
+)
+PYTHON_COMPAT=(
+ ${PYTHON_COMPAT_REAL[@]}
+ # these versions provide built-in argparse
+ # but we still list them to warn user to migrate
+ python{2_7,3_2,3_3} pypy{1_8,1_9}
+)
inherit distutils-r1
@@ -19,6 +27,30 @@ IUSE=""
DEPEND="dev-python/setuptools"
+pkg_pretend() {
+ local x
+ for x in ${PYTHON_COMPAT_REAL[@]}; do
+ if use python_targets_${x}; then
+ return
+ fi
+ done
+
+ ewarn 'You have installed this version of argparse only for Python'
+ ewarn 'implementations which provide the argparse module already.'
+ ewarn 'Most likely, this means that something in your system depends on'
+ ewarn 'dev-python/argparse instead of virtual/python-argparse.'
+ ewarn
+ ewarn 'Please try running the following command or an equivalent one:'
+ ewarn
+ ewarn ' emerge --verbose --depclean dev-python/argparse'
+ ewarn
+ ewarn 'If your package manager refuses to uninstall the package due to'
+ ewarn 'unsatisfied dependencies, please first try re-installing the listed'
+ ewarn 'packages and running --depclean again. If that does not help, please'
+ ewarn 'report a bug against the package, requesting its maintainer to fix'
+ ewarn 'the dependency on argparse to use virtual/argparse.'
+}
+
python_test() {
COLUMNS=80 PYTHONPATH="${BUILD_DIR}/lib" \
"${PYTHON}" test/test_argparse.py