summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-08 17:12:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-08 17:12:56 +0000
commit64236b188cdf1459816d4abe9801eb23eeb711c6 (patch)
tree1f4581c4b699332160669e7cd302004ea7b21a07 /dev-python/arrayterator/arrayterator-1.0.1.ebuild
parentMaking CONFIG_CHECK non-fatal for userland ebuilds, see bug 283320. (diff)
downloadgentoo-2-64236b188cdf1459816d4abe9801eb23eeb711c6.tar.gz
gentoo-2-64236b188cdf1459816d4abe9801eb23eeb711c6.tar.bz2
gentoo-2-64236b188cdf1459816d4abe9801eb23eeb711c6.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14218-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/arrayterator/arrayterator-1.0.1.ebuild')
-rw-r--r--dev-python/arrayterator/arrayterator-1.0.1.ebuild29
1 files changed, 22 insertions, 7 deletions
diff --git a/dev-python/arrayterator/arrayterator-1.0.1.ebuild b/dev-python/arrayterator/arrayterator-1.0.1.ebuild
index 0213af0507f3..cfa729819f8d 100644
--- a/dev-python/arrayterator/arrayterator-1.0.1.ebuild
+++ b/dev-python/arrayterator/arrayterator-1.0.1.ebuild
@@ -1,20 +1,35 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/arrayterator-1.0.1.ebuild,v 1.1 2009/09/07 19:03:09 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/arrayterator-1.0.1.ebuild,v 1.2 2009/09/08 17:12:56 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
-DESCRIPTION="This class creates a buffered iterator for reading big arrays in
-small contiguous blocks."
+DESCRIPTION="This class creates a buffered iterator for reading big arrays in small contiguous blocks."
HOMEPAGE="http://pypi.python.org/pypi/arrayterator"
-
SRC_URI="http://cheeseshop.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-#IUSE="server"
IUSE=""
-RDEPEND="virtual/python
- >=dev-python/numpy-1.0_rc1"
+
+RDEPEND=">=dev-python/numpy-1.0_rc1"
DEPEND="${RDEPEND}
>=dev-python/setuptools-0.6_rc3"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ cd tests
+
+ testing() {
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" -c "import test_stochastic; test_stochastic.test()"
+ }
+ python_execute_function testing
+}
+
+pkg_postinst() {
+ python_mod_optimize arrayterator.py
+}