summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-08 00:21:37 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-08 00:21:37 +0000
commit5637613c2b62ea1ffa7e84187fcec57eb3165144 (patch)
treef02ad8fd0aeca148c6b3a6c871fef08abbce0fa2 /dev-python/astng
parentFix dependencies. (diff)
downloadgentoo-2-5637613c2b62ea1ffa7e84187fcec57eb3165144.tar.gz
gentoo-2-5637613c2b62ea1ffa7e84187fcec57eb3165144.tar.bz2
gentoo-2-5637613c2b62ea1ffa7e84187fcec57eb3165144.zip
Fix dependencies.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/astng')
-rw-r--r--dev-python/astng/astng-0.20.1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/astng/astng-0.20.1.ebuild b/dev-python/astng/astng-0.20.1.ebuild
index fe1ee5c06686..08e0b0c13f5d 100644
--- a/dev-python/astng/astng-0.20.1.ebuild
+++ b/dev-python/astng/astng-0.20.1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.20.1.ebuild,v 1.1 2010/05/13 18:18:39 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.20.1.ebuild,v 1.2 2010/06/08 00:21:37 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
@@ -17,10 +18,10 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
IUSE="test"
-RDEPEND=">=dev-python/logilab-common-0.39.0"
+# Version specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.49.0"
DEPEND="${RDEPEND}
test? ( >=dev-python/egenix-mx-base-3.0.0 )"
-RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/logilab-${P}"
@@ -60,5 +61,5 @@ src_install() {
# Remove unittests since they're just needed during build-time
rm -fr "${sdir}/astng/test" || die
}
- python_execute_function --action-message 'Deletion of unneeded files with Python ${PYTHON_ABI}' deletion_of_unneeded_files
+ python_execute_function -q deletion_of_unneeded_files
}