summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-25 14:51:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-25 14:51:27 +0000
commita7a2a2b6dcfeb6a8ec62f6181606c11f249ffd2d (patch)
treeb846131cbe0fbbde92d3878be8c9d5ecae131d83 /dev-python/astng
parentStable on alpha, bug #278824 (diff)
downloadgentoo-2-a7a2a2b6dcfeb6a8ec62f6181606c11f249ffd2d.tar.gz
gentoo-2-a7a2a2b6dcfeb6a8ec62f6181606c11f249ffd2d.tar.bz2
gentoo-2-a7a2a2b6dcfeb6a8ec62f6181606c11f249ffd2d.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14155-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/astng')
-rw-r--r--dev-python/astng/ChangeLog6
-rw-r--r--dev-python/astng/astng-0.19.0.ebuild54
2 files changed, 37 insertions, 23 deletions
diff --git a/dev-python/astng/ChangeLog b/dev-python/astng/ChangeLog
index d2f4c5956a1a..fcb33428f48b 100644
--- a/dev-python/astng/ChangeLog
+++ b/dev-python/astng/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/astng
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.22 2009/06/19 13:08:17 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.23 2009/08/25 14:51:26 arfrever Exp $
+
+ 25 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ astng-0.19.0.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*astng-0.19.0 (19 Jun 2009)
diff --git a/dev-python/astng/astng-0.19.0.ebuild b/dev-python/astng/astng-0.19.0.ebuild
index 78711404e903..3d6450993631 100644
--- a/dev-python/astng/astng-0.19.0.ebuild
+++ b/dev-python/astng/astng-0.19.0.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.19.0.ebuild,v 1.1 2009/06/19 13:08:17 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.19.0.ebuild,v 1.2 2009/08/25 14:51:27 arfrever Exp $
-inherit python distutils
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
HOMEPAGE="http://www.logilab.org/projects/astng/"
@@ -17,38 +20,45 @@ RDEPEND=">=dev-python/logilab-common-0.39.0"
DEPEND="${RDEPEND}
test? ( >=dev-python/egenix-mx-base-3.0.0 )"
+RESTRICT_PYTHON_ABIS="3*"
+
PYTHON_MODNAME="logilab"
S="${WORKDIR}/logilab-${P}"
src_test() {
- local sdir="${T}/test/$(python_get_sitedir)"
+ testing() {
+ local sdir="${T}/test/$(python_get_sitedir)"
- # This is a hack to make tests work without installing to the live
- # filesystem. We copy part of the logilab site-packages to a temporary
- # dir, install there, and run from there.
- mkdir -p "${sdir}/logilab" || die
- cp -r "$(python_get_sitedir)/logilab/common" "${sdir}/logilab" \
- || die "copying logilab-common failed!"
+ # This is a hack to make tests work without installing to the live
+ # filesystem. We copy part of the logilab site-packages to a temporary
+ # dir, install there, and run from there.
+ mkdir -p "${sdir}/logilab" || die
+ cp -r "$(python_get_sitedir)/logilab/common" "${sdir}/logilab" || die "copying logilab-common failed!"
- ${python} setup.py install --root="${T}/test" || die "test copy failed"
+ "$(PYTHON)" setup.py install --root="${T}/test" || die "test copy failed"
- # Pytest picks up tests relative to the current dir, so cd in.
- pushd "${sdir}/logilab/astng" >/dev/null || die
- PYTHONPATH="${sdir}" pytest -v || die "tests failed"
- popd >/dev/null
+ # Pytest picks up tests relative to the current dir, so cd in.
+ pushd "${sdir}/logilab/astng" > /dev/null || die
+ PYTHONPATH="${sdir}" pytest -v || die "tests failed"
+ popd > /dev/null
+ }
+ python_execute_function testing
}
src_install() {
- local sdir="${D}/$(python_get_sitedir)/logilab"
-
distutils_src_install
- # we need to remove this file because it collides with the one
- # from logilab-common (which we depend on).
- # Bug 111970 and bug 223025
- rm "${sdir}/__init__.py" || die
+ deletion_of_unneeded_files() {
+ local sdir="${D}/$(python_get_sitedir)/logilab"
+
+ # we need to remove this file because it collides with the one
+ # from logilab-common (which we depend on).
+ # Bug 111970 and bug 223025
+ rm "${sdir}/__init__.py" || die
- # Remove unittests since they're just needed during build-time
- rm -rf "${sdir}/astng/test" || die
+ # Remove unittests since they're just needed during build-time
+ rm -rf "${sdir}/astng/test" || die
+ }
+ python_execute_function --action-message 'Deletion of unneeded files with Python ${PYTHON_ABI}' deletion_of_unneeded_files
}