summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-06-28 06:05:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-06-28 06:05:53 +0000
commit089422b947fd0f8f57898b1ab4f7478126b33b1b (patch)
tree05373ab94c90780a225f4f9d7c5ab42cc0bfa8cd /dev-python/authres
parentBump (diff)
downloadgentoo-2-089422b947fd0f8f57898b1ab4f7478126b33b1b.tar.gz
gentoo-2-089422b947fd0f8f57898b1ab4f7478126b33b1b.tar.bz2
gentoo-2-089422b947fd0f8f57898b1ab4f7478126b33b1b.zip
Bump
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/authres')
-rw-r--r--dev-python/authres/ChangeLog8
-rw-r--r--dev-python/authres/authres-0.402.ebuild29
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/authres/ChangeLog b/dev-python/authres/ChangeLog
index 8cab11ad901e..0c767b0ed2bb 100644
--- a/dev-python/authres/ChangeLog
+++ b/dev-python/authres/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/authres
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/authres/ChangeLog,v 1.6 2012/05/09 03:44:24 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/authres/ChangeLog,v 1.7 2012/06/28 06:05:53 patrick Exp $
+
+*authres-0.402 (28 Jun 2012)
+
+ 28 Jun 2012; Patrick Lauer <patrick@gentoo.org> +authres-0.402.ebuild:
+ Bump
09 May 2012; Mike Gilbert <floppym@gentoo.org> -authres-0.3.ebuild:
Just remove the old version instead.
@@ -27,4 +32,3 @@
+metadata.xml:
Initial import, ebuild written by me. Fixes #410907 by Ian Delaney
<johneed@hotmail.com>
-
diff --git a/dev-python/authres/authres-0.402.ebuild b/dev-python/authres/authres-0.402.ebuild
new file mode 100644
index 000000000000..01a6d0236923
--- /dev/null
+++ b/dev-python/authres/authres-0.402.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/authres/authres-0.402.ebuild,v 1.1 2012/06/28 06:05:53 patrick Exp $
+
+EAPI=4
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5"
+
+inherit distutils
+
+DESCRIPTION="Authentication Results Header Module"
+HOMEPAGE="https://launchpad.net/authentication-results-python http://pypi.python.org/pypi/authres"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DOCS="CHANGES README"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" \
+ -c "import sys, ${PN}, doctest; f, t = doctest.testfile('${PN}/tests'); \
+ sys.exit(bool(f))" || return
+ }
+ python_execute_function testing
+}