summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-13 07:37:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-13 07:37:58 +0000
commita6ad33102b22d36d057d6d17bc7067518a6bd39a (patch)
tree2fee7b62205822910c8b3fa7599a0638b5b8f8b2 /dev-python/autopep8
parentCorrections to attain intended changes (diff)
downloadgentoo-2-a6ad33102b22d36d057d6d17bc7067518a6bd39a.tar.gz
gentoo-2-a6ad33102b22d36d057d6d17bc7067518a6bd39a.tar.bz2
gentoo-2-a6ad33102b22d36d057d6d17bc7067518a6bd39a.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/ChangeLog7
-rw-r--r--dev-python/autopep8/autopep8-0.8.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/autopep8/ChangeLog b/dev-python/autopep8/ChangeLog
index e9038d09c5e0..9c22a2618aed 100644
--- a/dev-python/autopep8/ChangeLog
+++ b/dev-python/autopep8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/autopep8
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.20 2012/09/27 05:49:23 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.21 2012/11/13 07:37:58 patrick Exp $
+
+*autopep8-0.8.2 (13 Nov 2012)
+
+ 13 Nov 2012; Patrick Lauer <patrick@gentoo.org> +autopep8-0.8.2.ebuild:
+ Bump
27 Sep 2012; Kacper Kowalik <xarthisius@gentoo.org> autopep8-0.8.1.ebuild:
Update dependency on dev-python/pep8. Thanks to Arfrever for reporting
diff --git a/dev-python/autopep8/autopep8-0.8.2.ebuild b/dev-python/autopep8/autopep8-0.8.2.ebuild
new file mode 100644
index 000000000000..e42df2b2f34f
--- /dev/null
+++ b/dev-python/autopep8/autopep8-0.8.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-0.8.2.ebuild,v 1.1 2012/11/13 07:37:58 patrick Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5"
+
+inherit distutils vcs-snapshot
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-python/pep8-1.3.2
+ dev-python/setuptools"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME=${PN}.py
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_${PN}.py
+ }
+ python_execute_function testing
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
+ ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
+ ewarn "(indentation checks inside triple-quotes)."
+ ewarn "If you do not want to be affected by this, then add the"
+ ewarn "following lines to your local package.mask:"
+ ewarn " >=dev-python/pep8-1.3"
+ ewarn " >=dev-python/autopep8-0.6"
+}