summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-22 01:27:25 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-22 01:27:25 +0000
commit9baad13d2d8d9377cce8ffd00353647557436cd0 (patch)
tree512cca926eb4731f2c55b05485004e64fb9119ea /dev-python/axiom
parentfix build with nls enabled (diff)
downloadgentoo-2-9baad13d2d8d9377cce8ffd00353647557436cd0.tar.gz
gentoo-2-9baad13d2d8d9377cce8ffd00353647557436cd0.tar.bz2
gentoo-2-9baad13d2d8d9377cce8ffd00353647557436cd0.zip
bump: add; pytest for test phase, test phase
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/axiom')
-rw-r--r--dev-python/axiom/ChangeLog9
-rw-r--r--dev-python/axiom/axiom-0.7.0.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-python/axiom/ChangeLog b/dev-python/axiom/ChangeLog
index 493c11bc817c..085de8ab7e7e 100644
--- a/dev-python/axiom/ChangeLog
+++ b/dev-python/axiom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/axiom
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/axiom/ChangeLog,v 1.43 2013/08/09 17:28:24 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/axiom/ChangeLog,v 1.44 2014/01/22 01:27:25 idella4 Exp $
+
+*axiom-0.7.0 (22 Jan 2014)
+
+ 22 Jan 2014; Ian Delaney <idella4@gentoo.org> +axiom-0.7.0.ebuild:
+ bump: add; pytest for test phase, test phase
09 Aug 2013; Michał Górny <mgorny@gentoo.org> axiom-0.6.0-r1.ebuild:
Own the dropin.cache for axiom.plugins.
diff --git a/dev-python/axiom/axiom-0.7.0.ebuild b/dev-python/axiom/axiom-0.7.0.ebuild
new file mode 100644
index 000000000000..a596633b155a
--- /dev/null
+++ b/dev-python/axiom/axiom-0.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/axiom/axiom-0.7.0.ebuild,v 1.1 2014/01/22 01:27:25 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="sqlite"
+
+inherit twisted-r1
+
+DESCRIPTION="Object database implemented on top of SQLite."
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodAxiom http://pypi.python.org/pypi/Axiom"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/epsilon-0.6.0-r2[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.5.30-sqlite3_3.6.4.patch" )
+
+TWISTED_PLUGINS+=( axiom.plugins )
+
+python_install() {
+ distutils-r1_python_install
+
+ touch "${D}$(python_get_sitedir)"/axiom/plugins/dropin.cache || die
+}
+
+python_install_all() {
+ dodoc NAME.txt
+
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ py.test ${PN}/test/ || die "testsuite failed under ${EPYTHON}"
+}