summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-08-17 17:08:02 +0000
committerTim Harder <radhermit@gentoo.org>2012-08-17 17:08:02 +0000
commite47282b89cbc14f90e35b76fa413ce9cdb7cf4e8 (patch)
tree0397cb969159a9d35430d5522050252ee7b42490 /dev-python/beautifulsoup
parentRemove old. (diff)
downloadgentoo-2-e47282b89cbc14f90e35b76fa413ce9cdb7cf4e8.tar.gz
gentoo-2-e47282b89cbc14f90e35b76fa413ce9cdb7cf4e8.tar.bz2
gentoo-2-e47282b89cbc14f90e35b76fa413ce9cdb7cf4e8.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/ChangeLog7
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.1.2.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index f9743c3a8898..96aa2381abce 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.69 2012/08/07 20:26:32 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.70 2012/08/17 17:08:02 radhermit Exp $
+
+*beautifulsoup-4.1.2 (17 Aug 2012)
+
+ 17 Aug 2012; Tim Harder <radhermit@gentoo.org> +beautifulsoup-4.1.2.ebuild:
+ Version bump.
07 Aug 2012; Alexis Ballier <aballier@gentoo.org> beautifulsoup-4.1.1.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.1.2.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.1.2.ebuild
new file mode 100644
index 000000000000..b47c6f15ecdf
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-4.1.2.ebuild,v 1.1 2012/08/17 17:08:02 radhermit Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5"
+PYTHON_TESTS_RESTRICTED_ABIS="*-pypy-*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="${PN}4"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Provides pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/
+ http://pypi.python.org/pypi/beautifulsoup4"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc test"
+
+DEPEND="doc? ( dev-python/sphinx )
+ test? ( dev-python/lxml )"
+RDEPEND=""
+
+PYTHON_MODNAME="bs4"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C doc html
+ fi
+}
+
+src_test() {
+ testing() {
+ cd "build-${PYTHON_ABI}/lib"
+ nosetests --verbosity="${PYTHON_TEST_VERBOSITY}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r doc/build/html/*
+ fi
+}