summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-23 00:32:36 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-23 00:32:36 +0000
commitaa135a6c5b9b50ffcf124d393461be12d2b5b22f (patch)
treee74c9cf2de05c7c7d7fb1b7b9126094d11c51d72 /dev-python/boto
parentDon't return an error exit status when decompressing zero-padded files (bug #... (diff)
downloadgentoo-2-aa135a6c5b9b50ffcf124d393461be12d2b5b22f.tar.gz
gentoo-2-aa135a6c5b9b50ffcf124d393461be12d2b5b22f.tar.bz2
gentoo-2-aa135a6c5b9b50ffcf124d393461be12d2b5b22f.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.23.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 3c6fddac3c4b..a54293266c3a 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.87 2014/01/03 03:46:06 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.88 2014/01/23 00:32:36 radhermit Exp $
+
+*boto-2.23.0 (23 Jan 2014)
+
+ 23 Jan 2014; Tim Harder <radhermit@gentoo.org> +boto-2.23.0.ebuild:
+ Version bump.
*boto-2.22.0 (03 Jan 2014)
diff --git a/dev-python/boto/boto-2.23.0.ebuild b/dev-python/boto/boto-2.23.0.ebuild
new file mode 100644
index 000000000000..de0bfe4e1495
--- /dev/null
+++ b/dev-python/boto/boto-2.23.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.23.0.ebuild,v 1.1 2014/01/23 00:32:36 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}