summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-02-20 05:41:50 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-02-20 05:41:50 +0000
commite0158f75f40d6dccc67afb84848358bf333af9d5 (patch)
tree1a35896fab6fa56529acb7952ee1b808b66d6ea4 /dev-python/boto
parentrevived boto-2.1.1.ebuild (diff)
downloadgentoo-2-e0158f75f40d6dccc67afb84848358bf333af9d5.tar.gz
gentoo-2-e0158f75f40d6dccc67afb84848358bf333af9d5.tar.bz2
gentoo-2-e0158f75f40d6dccc67afb84848358bf333af9d5.zip
readding boto-2.1.1 as sys-cluster/nova requires it
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog5
-rw-r--r--dev-python/boto/boto-2.1.1.ebuild28
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 9a6528cd8863..cde61967f8d2 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.55 2013/02/05 01:36:52 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.56 2013/02/20 05:41:50 prometheanfire Exp $
+
+ 20 Feb 2013; Matthew Thode <prometheanfire@gentoo.org> boto-2.1.1.ebuild:
+ readding boto-2.1.1 as sys-cluster/nova requires it
05 Feb 2013; Tim Harder <radhermit@gentoo.org> -boto-2.0.ebuild,
-boto-2.1.1.ebuild, -boto-2.2.2.ebuild, -boto-2.2.2-r1.ebuild,
diff --git a/dev-python/boto/boto-2.1.1.ebuild b/dev-python/boto/boto-2.1.1.ebuild
index e69de29bb2d1..de174af0ed8b 100644
--- a/dev-python/boto/boto-2.1.1.ebuild
+++ b/dev-python/boto/boto-2.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.1.1.ebuild,v 1.4 2013/02/20 05:41:50 prometheanfire Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/m2crypto )"
+RDEPEND="dev-python/m2crypto"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}