summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 14:39:48 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 14:39:48 +0000
commit3dfac3149747d906fc1c761d5cd6f2fd78fec02a (patch)
treeacb1cca1b4f6fe7fddbbfde4c50a3f4845d97795 /dev-python/buildutils
parentUse $(PYTHON -f) instead of ${python}. (diff)
downloadgentoo-2-3dfac3149747d906fc1c761d5cd6f2fd78fec02a.tar.gz
gentoo-2-3dfac3149747d906fc1c761d5cd6f2fd78fec02a.tar.bz2
gentoo-2-3dfac3149747d906fc1c761d5cd6f2fd78fec02a.zip
Use $(PYTHON -f) instead of ${python}.
(Portage version: 15324-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/buildutils')
-rw-r--r--dev-python/buildutils/buildutils-0.3.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/buildutils/buildutils-0.3.ebuild b/dev-python/buildutils/buildutils-0.3.ebuild
index c7c5fea01fb1..817344e6e5ed 100644
--- a/dev-python/buildutils/buildutils-0.3.ebuild
+++ b/dev-python/buildutils/buildutils-0.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/buildutils/buildutils-0.3.ebuild,v 1.3 2009/10/10 11:58:20 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/buildutils/buildutils-0.3.ebuild,v 1.4 2010/02/06 14:39:48 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils eutils
@@ -32,7 +33,7 @@ src_compile() {
distutils_src_compile
if use doc; then
einfo "Generation of documentation"
- "${python}" setup.py pudge || die "Generation of documentation failed"
+ "$(PYTHON -f)" setup.py pudge || die "Generation of documentation failed"
fi
}