summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-12-01 17:48:28 +0000
committerMike Gilbert <floppym@gentoo.org>2014-12-01 17:48:28 +0000
commitd50ed836371bdb8b42fcba59ce8d9ad8d4b72f1c (patch)
tree5598c1be7862d35455c53b8121819348c7ccd543 /dev-python/cffi
parentnet-analyzer/openvas: Version Bump; drop old (diff)
downloadgentoo-2-d50ed836371bdb8b42fcba59ce8d9ad8d4b72f1c.tar.gz
gentoo-2-d50ed836371bdb8b42fcba59ce8d9ad8d4b72f1c.tar.bz2
gentoo-2-d50ed836371bdb8b42fcba59ce8d9ad8d4b72f1c.zip
Use in-source build to avoid a race. Reported by remi`.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/ChangeLog6
-rw-r--r--dev-python/cffi/cffi-0.8.1.ebuild5
-rw-r--r--dev-python/cffi/cffi-0.8.2.ebuild5
-rw-r--r--dev-python/cffi/cffi-0.8.6.ebuild5
4 files changed, 17 insertions, 4 deletions
diff --git a/dev-python/cffi/ChangeLog b/dev-python/cffi/ChangeLog
index 706c6851edd7..e236762adb7d 100644
--- a/dev-python/cffi/ChangeLog
+++ b/dev-python/cffi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/cffi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.40 2014/11/05 02:42:17 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.41 2014/12/01 17:48:28 floppym Exp $
+
+ 01 Dec 2014; Mike Gilbert <floppym@gentoo.org> cffi-0.8.1.ebuild,
+ cffi-0.8.2.ebuild, cffi-0.8.6.ebuild:
+ Use in-source build to avoid a race. Reported by remi`.
05 Nov 2014; Patrick Lauer <patrick@gentoo.org> cffi-0.8.6.ebuild:
Stable for x86 and amd64 to make bcrypt happy
diff --git a/dev-python/cffi/cffi-0.8.1.ebuild b/dev-python/cffi/cffi-0.8.1.ebuild
index f67e5eea5ed1..9ffea81c9300 100644
--- a/dev-python/cffi/cffi-0.8.1.ebuild
+++ b/dev-python/cffi/cffi-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.1.ebuild,v 1.14 2014/08/13 17:19:08 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.1.ebuild,v 1.15 2014/12/01 17:48:28 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
@@ -21,6 +21,9 @@ RDEPEND="virtual/libffi
dev-python/pytest[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
python_compile_all() {
use doc && emake -C doc html
}
diff --git a/dev-python/cffi/cffi-0.8.2.ebuild b/dev-python/cffi/cffi-0.8.2.ebuild
index 0681e6781972..64c15e58eb11 100644
--- a/dev-python/cffi/cffi-0.8.2.ebuild
+++ b/dev-python/cffi/cffi-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.2.ebuild,v 1.10 2014/08/13 17:19:08 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.2.ebuild,v 1.11 2014/12/01 17:48:28 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
@@ -21,6 +21,9 @@ RDEPEND="virtual/libffi
dev-python/pytest[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
python_compile_all() {
use doc && emake -C doc html
}
diff --git a/dev-python/cffi/cffi-0.8.6.ebuild b/dev-python/cffi/cffi-0.8.6.ebuild
index 79b4ae4d96a5..8d6219055f14 100644
--- a/dev-python/cffi/cffi-0.8.6.ebuild
+++ b/dev-python/cffi/cffi-0.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.6.ebuild,v 1.5 2014/11/05 02:42:17 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.6.ebuild,v 1.6 2014/12/01 17:48:28 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
@@ -21,6 +21,9 @@ RDEPEND="virtual/libffi
dev-python/pytest[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
python_compile_all() {
use doc && emake -C doc html
}