summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-18 14:50:08 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-18 14:50:08 +0000
commit3558aafe1366a8311d707910066168fff6e03ef8 (patch)
tree8b8a40d01c86642da3302481ca2b3c9647138352 /dev-python/chaco
parentVersion bump. (diff)
downloadgentoo-2-3558aafe1366a8311d707910066168fff6e03ef8.tar.gz
gentoo-2-3558aafe1366a8311d707910066168fff6e03ef8.tar.bz2
gentoo-2-3558aafe1366a8311d707910066168fff6e03ef8.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/chaco')
-rw-r--r--dev-python/chaco/chaco-3.3.1.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/chaco/chaco-3.3.1.ebuild b/dev-python/chaco/chaco-3.3.1.ebuild
deleted file mode 100644
index d50571ecb3bb..000000000000
--- a/dev-python/chaco/chaco-3.3.1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/chaco-3.3.1.ebuild,v 1.3 2010/08/04 23:28:21 bicatali Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils virtualx
-
-MY_PN="Chaco"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Interactive plotting toolkit"
-HOMEPAGE="http://code.enthought.com/projects/chaco http://pypi.python.org/pypi/Chaco"
-SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/enable-3.3.1
- >=dev-python/enthoughtbase-3.0.5
- dev-python/numpy"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/setupdocs
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- x11-apps/xhost )
- test? (
- dev-python/coverage
- >=dev-python/nose-0.10.3
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- x11-apps/xhost
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-PYTHON_MODNAME="enthought"
-
-src_prepare() {
- # "${S}/enthought/chaco2/tests does not exist.
- sed -e "s:,enthought/chaco2/tests::" -i setup.cfg || die "sed setup.cfg failed"
-
- sed \
- -e "s/self.run_command('build_docs')/pass/" \
- -e "/setupdocs>=1.0/d" \
- -i setup.py || die "sed setup.py failed"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- doc_generation() {
- "$(PYTHON -f)" setup.py build_docs --formats=html,pdf || die "Generation of documentation failed"
- }
- maketype="doc_generation" virtualmake
- fi
-}
-
-src_test() {
- maketype="distutils_src_test" virtualmake
-}
-
-src_install() {
- find "${S}" -name "*LICENSE.txt" -delete
- distutils_src_install
- dodoc docs/*.txt
- insinto /usr/share/doc/${PF}
- if use doc; then
- doins -r build/docs/html build/docs/latex/*.pdf || die
- fi
- if use examples; then
- doins -r examples || die
- fi
-}