summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-02 09:49:33 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-02 09:49:33 +0000
commit7be4af28edd603f19729ce7765b628312f43fe5c (patch)
tree1efbc14ce2feb4f25d011e88959f4ebc86c033e5 /dev-python/chameleon
parentReplace multilib_is_native_abi with multilib_build_binaries (diff)
downloadgentoo-2-7be4af28edd603f19729ce7765b628312f43fe5c.tar.gz
gentoo-2-7be4af28edd603f19729ce7765b628312f43fe5c.tar.bz2
gentoo-2-7be4af28edd603f19729ce7765b628312f43fe5c.zip
bump; drop pypy2_0 add py3.4 support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/chameleon')
-rw-r--r--dev-python/chameleon/ChangeLog7
-rw-r--r--dev-python/chameleon/chameleon-2.15.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/chameleon/ChangeLog b/dev-python/chameleon/ChangeLog
index 49a73c57d3b1..c2f80383d657 100644
--- a/dev-python/chameleon/ChangeLog
+++ b/dev-python/chameleon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/chameleon
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.23 2014/03/31 20:42:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.24 2014/05/02 09:49:33 idella4 Exp $
+
+*chameleon-2.15 (02 May 2014)
+
+ 02 May 2014; Ian Delaney <idella4@gentoo.org> +chameleon-2.15.ebuild:
+ bump; drop pypy2_0 add py3.4 support
31 Mar 2014; Michał Górny <mgorny@gentoo.org> chameleon-2.11-r1.ebuild,
chameleon-2.12.ebuild, chameleon-2.13.ebuild, chameleon-2.14.ebuild:
diff --git a/dev-python/chameleon/chameleon-2.15.ebuild b/dev-python/chameleon/chameleon-2.15.ebuild
new file mode 100644
index 000000000000..76d60175cbf0
--- /dev/null
+++ b/dev-python/chameleon/chameleon-2.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/chameleon-2.15.ebuild,v 1.1 2014/05/02 09:49:33 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Chameleon"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="http://chameleon.repoze.org http://pypi.python.org/pypi/Chameleon"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( _build/html/{[a-z]*,_static} )
+
+ distutils-r1_python_install_all
+}