summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-04-12 16:29:42 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-04-12 16:29:42 +0000
commit769b3c59831ae29e7bd2eb723e3904782b2c0cec (patch)
treec091e80452203794d330140dcbae4f6bcead24c0 /dev-python/cheetah/cheetah-2.0_rc8.ebuild
parentHAL compiles on Gentoo/FreeBSD (diff)
downloadgentoo-2-769b3c59831ae29e7bd2eb723e3904782b2c0cec.tar.gz
gentoo-2-769b3c59831ae29e7bd2eb723e3904782b2c0cec.tar.bz2
gentoo-2-769b3c59831ae29e7bd2eb723e3904782b2c0cec.zip
Version bump.
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-python/cheetah/cheetah-2.0_rc8.ebuild')
-rw-r--r--dev-python/cheetah/cheetah-2.0_rc8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/cheetah/cheetah-2.0_rc8.ebuild b/dev-python/cheetah/cheetah-2.0_rc8.ebuild
new file mode 100644
index 000000000000..7b607336f2d3
--- /dev/null
+++ b/dev-python/cheetah/cheetah-2.0_rc8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/cheetah-2.0_rc8.ebuild,v 1.1 2007/04/12 16:29:42 pythonhead Exp $
+
+NEED_PYTHON=2.2
+
+inherit distutils
+
+MY_PN=Cheetah
+MY_P=${MY_PN}-${PV/_}
+
+DESCRIPTION="Python-powered template engine and code generator."
+HOMEPAGE="http://www.cheetahtemplate.org/"
+SRC_URI="mirror://sourceforge/cheetahtemplate/${MY_P}.tar.gz"
+LICENSE="PSF-2.2"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+PYTHON_MODNAME="Cheetah"
+DOCS="README CHANGES TODO"
+
+pkg_postinst() {
+ ewarn "This release requires re-compilation of all compiled templates!"
+}
+
+src_test() {
+ PYTHONPATH=$(ls -d ./build/lib.*) "${python}" src/Tests/Test.py || die "tests failed"
+}