summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-10-04 17:28:51 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-10-04 17:28:51 +0000
commitbd320c80b765c7a549f3a3a0f374ca2e79b8ee92 (patch)
treeba8742de12a351d9e9238a3a9f4585f459b0ad23 /dev-python/cheetah
parentx86 stable, bug #239537 (diff)
downloadgentoo-2-bd320c80b765c7a549f3a3a0f374ca2e79b8ee92.tar.gz
gentoo-2-bd320c80b765c7a549f3a3a0f374ca2e79b8ee92.tar.bz2
gentoo-2-bd320c80b765c7a549f3a3a0f374ca2e79b8ee92.zip
Revision bump. Fixes bug #237214. Thanks to Martin Zibricky <matysek03@seznam.cz> for the patch
(Portage version: 2.2_rc8/cvs/Linux 2.6.18-gentoo-r3 i686)
Diffstat (limited to 'dev-python/cheetah')
-rw-r--r--dev-python/cheetah/ChangeLog11
-rw-r--r--dev-python/cheetah/cheetah-0.9.18-r1.ebuild25
-rw-r--r--dev-python/cheetah/files/Cheetah-0.9.18__future__imports.patch58
3 files changed, 92 insertions, 2 deletions
diff --git a/dev-python/cheetah/ChangeLog b/dev-python/cheetah/ChangeLog
index 809253ae20e4..38d008bc512d 100644
--- a/dev-python/cheetah/ChangeLog
+++ b/dev-python/cheetah/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/cheetah
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/ChangeLog,v 1.38 2007/11/26 19:48:05 pythonhead Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/ChangeLog,v 1.39 2008/10/04 17:28:50 neurogeek Exp $
+
+*cheetah-0.9.18-r1 (04 Oct 2008)
+
+ 04 Oct 2008; Jesus Rivero <neurogeek@gentoo.org>
+ +files/Cheetah-0.9.18__future__imports.patch, +cheetah-0.9.18-r1.ebuild:
+ Revision bump. Fixes bug #237214. Thanks to Martin Zibricky
+ <matysek03@seznam.cz> for the patch
*cheetah-2.0.1 (26 Nov 2007)
diff --git a/dev-python/cheetah/cheetah-0.9.18-r1.ebuild b/dev-python/cheetah/cheetah-0.9.18-r1.ebuild
new file mode 100644
index 000000000000..e21404167156
--- /dev/null
+++ b/dev-python/cheetah/cheetah-0.9.18-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/cheetah-0.9.18-r1.ebuild,v 1.1 2008/10/04 17:28:50 neurogeek Exp $
+
+inherit distutils
+
+MY_P=${P/ch/Ch}
+
+DESCRIPTION="Python-powered template engine and code generator."
+HOMEPAGE="http://www.cheetahtemplate.org/"
+SRC_URI="mirror://sourceforge/cheetahtemplate/${MY_P}.tar.gz"
+LICENSE="PSF-2.2"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+SLOT="0"
+DEPEND=">=dev-lang/python-2.2"
+S=${WORKDIR}/${MY_P}
+
+PYTHON_MODNAME="Cheetah"
+DOCS="README CHANGES TODO"
+
+src_unpack(){
+ distutils_src_unpack
+ epatch "${FILESDIR}"/${MY_P}__future__imports.patch
+}
diff --git a/dev-python/cheetah/files/Cheetah-0.9.18__future__imports.patch b/dev-python/cheetah/files/Cheetah-0.9.18__future__imports.patch
new file mode 100644
index 000000000000..7f73360ed540
--- /dev/null
+++ b/dev-python/cheetah/files/Cheetah-0.9.18__future__imports.patch
@@ -0,0 +1,58 @@
+diff -Naur Cheetah-0.9.18-orig/src/NameMapper.py Cheetah-0.9.18/src/NameMapper.py
+--- Cheetah-0.9.18-orig/src/NameMapper.py 2008-09-08 12:53:08.000000000 +0000
++++ Cheetah-0.9.18/src/NameMapper.py 2008-09-08 13:07:57.000000000 +0000
+@@ -1,6 +1,12 @@
+ #!/usr/bin/env python
+ # $Id: Cheetah-0.9.18__future__imports.patch,v 1.1 2008/10/04 17:28:51 neurogeek Exp $
+
++from __future__ import generators
++import types
++from types import StringType, InstanceType, ClassType, TypeType
++from pprint import pformat
++import inspect
++
+ """This module supports Cheetah's optional NameMapper syntax.
+
+ Overview
+@@ -143,12 +149,6 @@
+ "\nChuck Esterbrook <echuck@mindspring.com>"
+ __revision__ = "$Revision: 1.1 $"[11:-2]
+
+-from __future__ import generators
+-import types
+-from types import StringType, InstanceType, ClassType, TypeType
+-from pprint import pformat
+-import inspect
+-
+ _INCLUDE_NAMESPACE_REPR_IN_NOTFOUND_EXCEPTIONS = False
+ _ALLOW_WRAPPING_OF_NOTFOUND_EXCEPTIONS = True
+ __all__ = ['NotFound',
+diff -Naur Cheetah-0.9.18-orig/src/Tests/NameMapper.py Cheetah-0.9.18/src/Tests/NameMapper.py
+--- Cheetah-0.9.18-orig/src/Tests/NameMapper.py 2008-09-08 12:53:08.000000000 +0000
++++ Cheetah-0.9.18/src/Tests/NameMapper.py 2008-09-08 13:03:27.000000000 +0000
+@@ -1,5 +1,12 @@
+ #!/usr/bin/env python
+ # $Id: Cheetah-0.9.18__future__imports.patch,v 1.1 2008/10/04 17:28:51 neurogeek Exp $
++
++from __future__ import generators
++import sys
++import types
++import os
++import os.path
++
+ """NameMapper Tests
+
+ Meta-Data
+@@ -12,12 +19,6 @@
+ __author__ = "Tavis Rudd <tavis@damnsimple.com>"
+ __revision__ = "$Revision: 1.1 $"[11:-2]
+
+-from __future__ import generators
+-import sys
+-import types
+-import os
+-import os.path
+-
+ import unittest_local_copy as unittest
+ from Cheetah.NameMapper import NotFound, valueForKey, \
+ valueForName, valueFromSearchList, valueFromFrame, valueFromFrameOrSearchList