summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-17 09:51:11 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-17 09:51:11 +0000
commit739e02c18dfab088890aab18c929dd9b7b64821b (patch)
treed64751e985081dbfa75dbd138b3a392f46ebcd87 /dev-python/click
parentUpdate stable mask for multilib (diff)
downloadgentoo-2-739e02c18dfab088890aab18c929dd9b7b64821b.tar.gz
gentoo-2-739e02c18dfab088890aab18c929dd9b7b64821b.tar.bz2
gentoo-2-739e02c18dfab088890aab18c929dd9b7b64821b.zip
bump; add IUSE doc examples test, missing dep and corresponding phases
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/ChangeLog7
-rw-r--r--dev-python/click/click-2.4.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/click/ChangeLog b/dev-python/click/ChangeLog
index 640a49a1e62e..daf39c54829c 100644
--- a/dev-python/click/ChangeLog
+++ b/dev-python/click/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/click
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/click/ChangeLog,v 1.1 2014/06/08 00:36:37 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/click/ChangeLog,v 1.2 2014/07/17 09:51:11 idella4 Exp $
+
+*click-2.4 (17 Jul 2014)
+
+ 17 Jul 2014; Ian Delaney <idella4@gentoo.org> +click-2.4.ebuild:
+ bump; add IUSE doc examples test, missing dep and corresponding phases
*click-2.0 (08 Jun 2014)
diff --git a/dev-python/click/click-2.4.ebuild b/dev-python/click/click-2.4.ebuild
new file mode 100644
index 000000000000..a7e2e1934ba8
--- /dev/null
+++ b/dev-python/click/click-2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/click/click-2.4.ebuild,v 1.1 2014/07/17 09:51:11 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ http://pypi.python.org/pypi/click"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc examples test"
+
+RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}