summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-09 07:00:16 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-09 07:00:16 +0000
commitbf2e0933a0c46ce81daff7d4955536e8a30783d4 (patch)
tree687abb82060c48f68095e3897816e566b7066f8b /dev-python/cx_Freeze
parentVersion bump. (diff)
downloadgentoo-2-bf2e0933a0c46ce81daff7d4955536e8a30783d4.tar.gz
gentoo-2-bf2e0933a0c46ce81daff7d4955536e8a30783d4.tar.bz2
gentoo-2-bf2e0933a0c46ce81daff7d4955536e8a30783d4.zip
migrate -> distutils-r1, fixes Bug #46705
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/cx_Freeze')
-rw-r--r--dev-python/cx_Freeze/ChangeLog10
-rw-r--r--dev-python/cx_Freeze/cx_Freeze-4.3.1-r1.ebuild25
2 files changed, 32 insertions, 3 deletions
diff --git a/dev-python/cx_Freeze/ChangeLog b/dev-python/cx_Freeze/ChangeLog
index a3f040225ac7..8073041cc3a0 100644
--- a/dev-python/cx_Freeze/ChangeLog
+++ b/dev-python/cx_Freeze/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cx_Freeze
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cx_Freeze/ChangeLog,v 1.2 2012/12/27 07:25:09 pinkbyte Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cx_Freeze/ChangeLog,v 1.3 2013/05/09 07:00:16 idella4 Exp $
+
+*cx_Freeze-4.3.1-r1 (09 May 2013)
+
+ 09 May 2013; Ian Delaney <idella4@gentoo.org> +cx_Freeze-4.3.1-r1.ebuild:
+ migrate -> distutils-r1, fixes Bug #46705
27 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> cx_Freeze-4.3.1.ebuild:
Drop obsolete USE-flag 'doc', wrt bug #448722. Thanks to Diego Elio Pettenò
@@ -11,4 +16,3 @@
18 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> +cx_Freeze-4.3.1.ebuild,
+metadata.xml:
Initial commit, wrt bug #184263
-
diff --git a/dev-python/cx_Freeze/cx_Freeze-4.3.1-r1.ebuild b/dev-python/cx_Freeze/cx_Freeze-4.3.1-r1.ebuild
new file mode 100644
index 000000000000..98fc1eb6ddfb
--- /dev/null
+++ b/dev-python/cx_Freeze/cx_Freeze-4.3.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cx_Freeze/cx_Freeze-4.3.1-r1.ebuild,v 1.1 2013/05/09 07:00:15 idella4 Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create standalone executables from Python scripts"
+HOMEPAGE="http://cx-freeze.sourceforge.net"
+SRC_URI="mirror://sourceforge/cx-freeze/${P}.tar.gz"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS=( README.txt )
+
+python_prepare() {
+ # do not strip binaries
+ sed -i -e '/extraArgs.append("-s")/d' setup.py || die 'sed on setup.py failed'
+}