summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-20 17:30:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-20 17:30:04 +0000
commit131027275345084fde006cc8f6db7faf30059b97 (patch)
treef9a24685c850d5e8a3f58cfb9c5a868d899f4fd6 /dev-python/dbus-python
parentold (diff)
downloadgentoo-2-131027275345084fde006cc8f6db7faf30059b97.tar.gz
gentoo-2-131027275345084fde006cc8f6db7faf30059b97.tar.bz2
gentoo-2-131027275345084fde006cc8f6db7faf30059b97.zip
ppc64 stable wrt #353708. drop old
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/ChangeLog6
-rw-r--r--dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild74
-rw-r--r--dev-python/dbus-python/dbus-python-0.83.1.ebuild80
-rw-r--r--dev-python/dbus-python/dbus-python-0.83.2.ebuild4
4 files changed, 7 insertions, 157 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index f60c4bcce679..35abd3aa506f 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.68 2011/02/28 01:00:01 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.69 2011/03/20 17:30:04 ssuominen Exp $
+
+ 20 Mar 2011; Samuli Suominen <ssuominen@gentoo.org>
+ dbus-python-0.83.2.ebuild:
+ ppc64 stable wrt #353708
28 Feb 2011; Brent Baude <ranger@gentoo.org> dbus-python-0.83.2.ebuild:
stable ppc, bug 353708
diff --git a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
deleted file mode 100644
index 475369377566..000000000000
--- a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.20 2010/12/24 13:22:30 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit multilib python
-
-DESCRIPTION="Python bindings for the D-Bus messagebus."
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings \
-http://dbus.freedesktop.org/doc/dbus-python/"
-SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="
- >=dev-libs/dbus-glib-0.71
- >=sys-apps/dbus-1.1.1"
-DEPEND="${RDEPEND}
- doc? ( =dev-python/epydoc-3* )
- test? ( dev-python/pygobject )
- dev-util/pkgconfig"
-
-src_prepare() {
- # Disable compiling of .pyc files.
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
-
- python_src_prepare
-}
-
-src_configure() {
- use prefix || EPREFIX=
-
- configuration() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable doc api-docs)
- }
- python_execute_function -s configuration
-}
-
-src_install() {
- python_src_install
-
- if use doc; then
- install_documentation() {
- dohtml api/* || return 1
- }
- python_execute_function -f -q -s install_documentation
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/
- doins -r examples || die
- fi
-
- find "${D}" -name "*.la" -delete || die "removing *.la files failed"
-}
-
-pkg_postinst() {
- python_mod_optimize dbus
-}
-
-pkg_postrm() {
- python_mod_cleanup dbus
-}
diff --git a/dev-python/dbus-python/dbus-python-0.83.1.ebuild b/dev-python/dbus-python/dbus-python-0.83.1.ebuild
deleted file mode 100644
index a91bfd3ebe2b..000000000000
--- a/dev-python/dbus-python/dbus-python-0.83.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.1.ebuild,v 1.6 2010/12/24 13:22:30 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit eutils multilib python
-
-DESCRIPTION="Python bindings for the D-Bus messagebus."
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings \
-http://dbus.freedesktop.org/doc/dbus-python/"
-SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="
- >=dev-libs/dbus-glib-0.71
- >=sys-apps/dbus-1.1.1"
-DEPEND="${RDEPEND}
- doc? ( =dev-python/epydoc-3* )
- test? ( dev-python/pygobject )
- dev-util/pkgconfig"
-
-src_prepare() {
- # Disable compiling of .pyc files.
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
-
- # Workaround testsuite issues
- epatch "${FILESDIR}/${PN}-0.83.1-workaround-broken-test.patch"
-
- python_src_prepare
-}
-
-src_configure() {
- configuration() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable doc api-docs)
- }
- python_execute_function -s configuration
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- python_src_test
-}
-
-src_install() {
- python_src_install
-
- if use doc; then
- install_documentation() {
- dohtml api/* || return 1
- }
- python_execute_function -f -q -s install_documentation
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/
- doins -r examples || die
- fi
-
- python_clean_installation_image
-}
-
-pkg_postinst() {
- python_mod_optimize dbus dbus_bindings.py
-}
-
-pkg_postrm() {
- python_mod_cleanup dbus dbus_bindings.py
-}
diff --git a/dev-python/dbus-python/dbus-python-0.83.2.ebuild b/dev-python/dbus-python/dbus-python-0.83.2.ebuild
index 5b4b983011f6..ff9a52616f01 100644
--- a/dev-python/dbus-python/dbus-python-0.83.2.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.83.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.2.ebuild,v 1.7 2011/02/28 01:00:01 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.2.ebuild,v 1.8 2011/03/20 17:30:04 ssuominen Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -17,7 +17,7 @@ SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="doc examples test"
RDEPEND="