summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-10-31 19:44:42 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-10-31 19:44:42 +0000
commit4bbd51ee8148da92557e1111921a42ac794ecba4 (patch)
treee26d8e0870f592b2fe435bdedbabd30c4f17ca2d /dev-python/dbus-python
parentBump to latest development release. (diff)
downloadgentoo-2-4bbd51ee8148da92557e1111921a42ac794ecba4.tar.gz
gentoo-2-4bbd51ee8148da92557e1111921a42ac794ecba4.tar.bz2
gentoo-2-4bbd51ee8148da92557e1111921a42ac794ecba4.zip
Restrict PyPy ABIs. Disable tests with 2.4 and 2.5 Python ABIs. Clean ebuild. Patch by Arfrever.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/ChangeLog6
-rw-r--r--dev-python/dbus-python/dbus-python-0.84.0.ebuild23
2 files changed, 16 insertions, 13 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 8b4b58974ab3..25b3594d167e 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.76 2011/10/29 19:18:57 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.77 2011/10/31 19:44:42 hwoarang Exp $
+
+ 31 Oct 2011; Markos Chandras <hwoarang@gentoo.org> dbus-python-0.84.0.ebuild:
+ Restrict PyPy ABIs. Disable tests with 2.4 and 2.5 Python ABIs. Clean ebuild.
+ Patch by Arfrever.
29 Oct 2011; Markus Meier <maekke@gentoo.org> dbus-python-0.84.0.ebuild:
arm stable, bug #387257
diff --git a/dev-python/dbus-python/dbus-python-0.84.0.ebuild b/dev-python/dbus-python/dbus-python-0.84.0.ebuild
index 26d3ffd14c49..3318d1f69517 100644
--- a/dev-python/dbus-python/dbus-python-0.84.0.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.84.0.ebuild
@@ -1,32 +1,31 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.84.0.ebuild,v 1.6 2011/10/29 19:18:57 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.84.0.ebuild,v 1.7 2011/10/31 19:44:42 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
+PYTHON_TESTS_RESTRICTED_ABIS="2.4 2.5"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-inherit eutils multilib python
+inherit eutils python
-DESCRIPTION="Python bindings for the D-Bus messagebus."
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings \
-http://dbus.freedesktop.org/doc/dbus-python/"
+DESCRIPTION="Python bindings for the D-Bus messagebus"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/"
SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-SLOT="0"
LICENSE="MIT"
+SLOT="0"
KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="doc examples test"
-RDEPEND="
- >=dev-libs/dbus-glib-0.88
+RDEPEND=">=dev-libs/dbus-glib-0.88
>=sys-apps/dbus-1.4.1"
DEPEND="${RDEPEND}
+ dev-util/pkgconfig
doc? ( =dev-python/epydoc-3* )
- test? ( dev-python/pygobject:2 )
- dev-util/pkgconfig"
+ test? ( dev-python/pygobject:2 )"
src_prepare() {
# Disable compiling of .pyc files.