summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-18 18:59:43 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-18 18:59:43 +0000
commit4be0fa21d28882ef646f972a34466bc569479b87 (patch)
treeec147bc7d59adc88395861bc43808d05d81a092a /dev-python/dbus-python
parentold. typo. (diff)
downloadgentoo-2-4be0fa21d28882ef646f972a34466bc569479b87.tar.gz
gentoo-2-4be0fa21d28882ef646f972a34466bc569479b87.tar.bz2
gentoo-2-4be0fa21d28882ef646f972a34466bc569479b87.zip
remove useless die, use emake in 0.83 and add call to python_need_rebuild per bug #244560.
(Portage version: 2.2_rc20/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/ChangeLog8
-rw-r--r--dev-python/dbus-python/dbus-python-0.71.ebuild22
-rw-r--r--dev-python/dbus-python/dbus-python-0.80.2.ebuild14
-rw-r--r--dev-python/dbus-python/dbus-python-0.82.4.ebuild14
-rw-r--r--dev-python/dbus-python/dbus-python-0.83.0.ebuild16
5 files changed, 29 insertions, 45 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 59ec9199856e..ecb3ef3e8938 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.42 2009/01/13 15:51:30 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.43 2009/01/18 18:59:43 eva Exp $
+
+ 18 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ -dbus-python-0.71.ebuild, dbus-python-0.80.2.ebuild,
+ dbus-python-0.82.4.ebuild, dbus-python-0.83.0.ebuild:
+ remove useless die, use emake in 0.83 and add call to python_need_rebuild
+ per bug #244560.
13 Jan 2009; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
gentopia is becoming freedesktop
diff --git a/dev-python/dbus-python/dbus-python-0.71.ebuild b/dev-python/dbus-python/dbus-python-0.71.ebuild
deleted file mode 100644
index f9d24914cbc2..000000000000
--- a/dev-python/dbus-python/dbus-python-0.71.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.71.ebuild,v 1.14 2007/07/06 17:32:48 hawking Exp $
-
-inherit distutils
-
-DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="http://dbus.freedesktop.org/"
-SRC_URI="http://dbus.freedesktop.org/releases/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 AFL-2.1 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-
-RDEPEND=">=dev-lang/python-2.4
- >=dev-python/pyrex-0.9.3-r2
- >=dev-libs/dbus-glib-0.71
- >=sys-apps/dbus-0.91"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-PYTHON_MODNAME="dbus"
diff --git a/dev-python/dbus-python/dbus-python-0.80.2.ebuild b/dev-python/dbus-python/dbus-python-0.80.2.ebuild
index 83ee04fea0c5..00da7341eafa 100644
--- a/dev-python/dbus-python/dbus-python-0.80.2.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.80.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.80.2.ebuild,v 1.14 2008/05/29 16:09:46 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.80.2.ebuild,v 1.15 2009/01/18 18:59:43 eva Exp $
inherit python multilib
@@ -27,14 +27,13 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # don't run py-compile
- sed -i \
- -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
- dbus/Makefile.in Makefile.in || die "sed in Makefile.in failed"
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
}
src_compile() {
- econf --docdir=/usr/share/doc/dbus-python-${PV} || die "econf failed"
+ econf --docdir=/usr/share/doc/dbus-python-${PV}
emake || die "emake failed"
}
@@ -44,6 +43,7 @@ src_install() {
pkg_postinst() {
python_version
+ python_need_rebuild
python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/dbus
}
diff --git a/dev-python/dbus-python/dbus-python-0.82.4.ebuild b/dev-python/dbus-python/dbus-python-0.82.4.ebuild
index db68029ec537..c952f6f490d6 100644
--- a/dev-python/dbus-python/dbus-python-0.82.4.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.82.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.82.4.ebuild,v 1.11 2008/11/09 11:59:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.82.4.ebuild,v 1.12 2009/01/18 18:59:43 eva Exp $
inherit python multilib
@@ -27,14 +27,13 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # don't run py-compile
- sed -i \
- -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
- Makefile.in || die "sed in Makefile.in failed"
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
}
src_compile() {
- econf --docdir=/usr/share/doc/dbus-python-${PV} || die "econf failed"
+ econf --docdir=/usr/share/doc/dbus-python-${PV}
emake || die "emake failed"
}
@@ -44,6 +43,7 @@ src_install() {
pkg_postinst() {
python_version
+ python_need_rebuild
python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/dbus
}
diff --git a/dev-python/dbus-python/dbus-python-0.83.0.ebuild b/dev-python/dbus-python/dbus-python-0.83.0.ebuild
index 2339b1392fc5..fd0b03d99d93 100644
--- a/dev-python/dbus-python/dbus-python-0.83.0.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.83.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0.ebuild,v 1.1 2008/08/15 04:10:20 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0.ebuild,v 1.2 2009/01/18 18:59:43 eva Exp $
inherit python multilib
@@ -27,23 +27,23 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # don't run py-compile
- sed -i \
- -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
- Makefile.in || die "sed in Makefile.in failed"
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
}
src_compile() {
- econf --docdir=/usr/share/doc/dbus-python-${PV} || die "econf failed"
+ econf --docdir=/usr/share/doc/dbus-python-${PV}
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
}
pkg_postinst() {
python_version
+ python_need_rebuild
python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/dbus
}