summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-02 00:45:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-02 00:45:44 +0000
commit5fd87a0c2af76a38e1554732d48a0dd2205fbcc2 (patch)
tree2e377a45c462bdfd5c7c835beb580379f63bfb18 /dev-python/dbus-python
parentMarked stable on AMD64 as requested by Michael "Mr. Bones" Sterrett <mr_bones... (diff)
downloadgentoo-2-5fd87a0c2af76a38e1554732d48a0dd2205fbcc2.tar.gz
gentoo-2-5fd87a0c2af76a38e1554732d48a0dd2205fbcc2.tar.bz2
gentoo-2-5fd87a0c2af76a38e1554732d48a0dd2205fbcc2.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 13874-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/ChangeLog6
-rw-r--r--dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild38
2 files changed, 32 insertions, 12 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index c5a21485f40c..6fd4116a1092 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.46 2009/03/10 15:35:12 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.47 2009/08/02 00:45:44 arfrever Exp $
+
+ 02 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ dbus-python-0.83.0-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
10 Mar 2009; Petteri Räty <betelgeuse@gentoo.org> metadata.xml:
Remove steev from metadata.xml as he isn't associated with this package
diff --git a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
index 97c06d24e47d..13a6954b2340 100644
--- a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.2 2009/03/10 15:33:46 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.3 2009/08/02 00:45:44 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit python multilib
@@ -23,22 +26,37 @@ DEPEND="${RDEPEND}
test? ( dev-python/pygobject )
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+RESTRICT_PYTHON_ABIS="3*"
- # disable pyc compiling
+src_prepare() {
+ # Disable compiling of .pyc files.
mv "${S}"/py-compile "${S}"/py-compile.orig
ln -s $(type -P true) "${S}"/py-compile
+
+ python_copy_sources
+}
+
+src_configure() {
+ configure_package() {
+ econf --docdir=/usr/share/doc/dbus-python-${PV}
+ }
+ python_execute_function -s configure_package
}
src_compile() {
- econf --docdir=/usr/share/doc/dbus-python-${PV}
- emake || die "emake failed"
+ build_package() {
+ emake
+ }
+ python_execute_function -s build_package
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ python_need_rebuild
+
+ install_package() {
+ emake DESTDIR="${D}" install
+ }
+ python_execute_function -s install_package
if use examples; then
insinto /usr/share/doc/${PF}/
@@ -47,9 +65,7 @@ src_install() {
}
pkg_postinst() {
- python_version
- python_need_rebuild
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/dbus
+ python_mod_optimize dbus
}
pkg_postrm() {